Xcode command-u


Hey Everyone,

My first post and I want to say big thank you for all Atom admins, this is amazing program I’m so new program and my new macbook too :slight_smile:. Guys I need help I downloaded Atom and Xcode then yesterday I typed Command-u then when I try C or C++ program I am getting error but my programs are working;

““GCC - error -> clang: warning: treating ‘c’ input as ‘c++’ when in C++ mode, this behaviour is deprecated””

this is my error.

I actually tried to uninstall Xcode but when I download Xcode again I got same error. Do I have to uninstall all files Xcode, because I couldn’n do it :expressionless:
What can I do guys? I’m new also on mac computer. I’m open all recommended not just this problem. Thank you guys.
Happy coding…




this is show my code problem as well. thanks



So are you getting this error when working with Atom? Or XCode?



Hey leedohm,
Sorry about my English, I’m getting this error when I working with Atom, but this became after type a few key which I was trying to find shortcut.
This error display bottom of Atom interface so my projects are working but when I create c or c++ workbench in Atom I can see this warning bottom of page.



And also other programs working well,



If you’re trying to figure out why your code isn’t compiling, I’m not sure that we can help you. Atom doesn’t support compiling or running code out of the box:

It sounds like you’re getting a linter warning, but other than that Atom is working fine.



Thank you for answer leedohm, actually I didn’t work on Javascript, just I used c programming and python with Atom.
I was looking for shortcuts in Atom when I was working c programming then I typed “command-u” I realized this warning bottom of page. Also still Atom is working but I can’t understand this error when became?
I will try your way I hope will work.