Workaround for Chrome 41 click-drag bug in VirtualBox?


#1

I hope to roll out Atom to my CS students when school starts in mid-August, but we use a VirtualBox environment.

Currently, because of the bug tracked (amongst other places) in Issue #6877, Atom is unusable.

Could a betting person could plan that the issue would be resolved by then? There hasn’t been any activity for almost a month.


#2

I’m not a betting man, which is probably why I wouldn’t put my money on it.
The issue indicates that testing for Chrome 42 hasn’t been completed yet, on none of the OSs.


#3

I was hoping, in lieu of the thing being fixed, that there might be a workaround. There was a launch-time config fix for the problem when it first emerged in Chrome, but I’m not familiar enough with the way Atom integrates to know if such is possible there, too.


#4

This was the exact same issue with Visual Studio Code when it was launched but it’s now fixed in v. 0.5.0. You can’t scroll x or y and you can’t drag and select text. As usual i end up back on tried and true Brackets.


#5

Hey! If im correct there is an issue with selecting text. I had the same issue with same Ubuntu distro.

Mouse integration worked for me:

  • Bottom VirtualBox menu / Input / Mouse integration

To turn off:

  • RIGHT CTRL, now the mouse is moveing freely. You can ALT + TAB in your host enviroment (WIN) or turn OFF the mouse integration from VirtualBox menu at the bottom of the screen.

Please give some feedback if this was helpful :slight_smile: