Wordwrapping (soft or hard) seems to be broken


#1

Downloaded the latest version 0.127.0 and the ability to word wrap seems to no longer work. I’ve tried to disable all additional plugins and it still doesn’t seem to wrap. It affects both wrapping at the end of the window as well as setting the characters in a line.

Anyone else having this issue?


#2

Toggle Editor: Soft Wrap is working fine for me with version 0.127.0.

I am using Windows 8.1, installed with chocolatey.

Any particular file types? Try running atom --safe to make sure all plugins are disabled.


#3

It seems the developers of Atom changed the setting title. Try deleting ‘softWrap’: true in your config, and add ‘softWrapped’: true instead (or you can check Soft Wrapped setting in your preference pane)


#4

sylund: That worked. Seems they changed the config property.


#5

That sure is a random change. It seems too minor a benefit to break things.


#6

This is the time to break things. Despite the widespread attention Atom has gotten, the 1.0 version has not been released yet. If breaking things now creates better consistency down the road, I’m all for it.


#7

Continuing on @leedohm’s reply, since we’re not at v1.0.0 yet, I’m glad the team is making breaking changes. Once we reach the v1.0.0 point, making these “random changes” will be much harder to justify, if justifiable at all. By breaking things now, we’ll all be in a much happier place going forward.


#8

It appears this change has been rolled back in 0.128.0 https://github.com/atom/atom/pull/3545