Won't install after latest Windows 10 updates


#1

I downloaded the latest Atom Windows installer from the https://atom.io/ homepage.

Watch what happens in the GIF below. Installation starts, you can see it in the task manager, then it just disappears.

I’m running latest version of Windows 10, all updates, and have tried restarting several times. I even tried disabling Windows Defender, but that didn’t help.


#2

The installer (called Squirrel), should leave a temporary log file behind at this location:
C:\Users\[username]\AppData\Local\SquirrelTemp
Actually, this should be the one I’m thinking of:

Can you check it out and perhaps post what happened there in the last few lines?


#3

Thanks.

So I cleared the log to start fresh. Then ran the AtomSetup.exe setup again. This is the entire log now:

2015-08-15 15:56:07> Program: Starting Squirrel Updater: --install .
2015-08-15 15:56:07> Program: Starting install, writing to C:\Users\Michael\AppData\Local\SquirrelTemp
2015-08-15 15:56:07> Program: About to install to: C:\Users\Michael\AppData\Local\atom
2015-08-15 15:56:07> CheckForUpdateImpl: Reading RELEASES file from C:\Users\Michael\AppData\Local\SquirrelTemp
2015-08-15 15:56:07> ApplyReleasesImpl: No release to install, running the app
2015-08-15 15:56:07> ApplyReleasesImpl: Squirrel Enabled Apps: [C:\Users\Michael\AppData\Local\atom\app-1.0.7\atom.exe]

#4

UPDATE: I got it working.

I had to un-install the existing version of Atom first. I guess this is where the Squirrel installer fails - it should at least advise you that Atom is already installed, instead of just doing nothing.

Anyway, the reason I was trying to install Atom while I already had it installed is because it’s throwing an error, and I was hoping a fresh install (or an in stall over top of the existing installation) would fix it. Apparently it didn’t. But I didn’t want to lose my packages.

On to more troubleshooting now.


#5

Have you opened an issue on the relevant repository for that original problem you’re trying to fix?


#6

That didn’t turn out to be a problem caused by Atom or any of the packages. Not directly.

The PHP Linter package was throwing an error any time I opened a page with PHP. What had happened - and I have no idea why it happened - is that the path to PHP was missing from Windows System Variables.

I put the path in, and the errors stopped happening. Problem solved.

Screenshot below shows the path to where PHP is on my system (D:\XAMPP\PHP). This system variable used to be there before the Windows 10 updates this week (I remember having to add it months ago to get PHP linter working properly), but as mentioned I don’t know why it would disappear after the latest Win 10 update.


#7

Weird. Thanks for updating the thread. Might come in handy if anybody else runs into something like this.