Windows Keybinding Issue


#1

Started mucking around with the vim-mode plugin when I realized that none of the keybindings for symbols/punctuation were working.

Numbers, ctrl+letters, and letters all work fine, but things like $, ^, and . do not.

I opened up the keybinding resolver.

Pressing $ shows shift briefly, followed by 4.
Pressing period shows 3/4.

I’m not sure where to file this bug. I don’t think it’s vim-mode or the resolver’s issue. I’m inclined to think atom/atom-keymap or atom/atom, but I’m not sure it’s not even atom/atom-shell.

Other resolutions for the curious:
, = 1/4
\ = U with an umlaut

  • and _ = 1/2
    numpad + = k
    numpad 1 - 9 = a - i
    ; = degree symbol

up/down/left/right/page up/page down/home/insert/delete are all accurate.


#2

Are you on a non-US keyboard?


#3

Nope. Just a plain old US Keyboard with qwerty as the mapping.


#4

But without the vim-mode plugin, things work?


#5

No, when removing the vim-mode package, I still have weird keybinding issues.

I just didn’t notice it until I installed the plugin because things like $ and ^ aren’t key bound anywhere else. Everything still shows up weird in the resolver. I’ll see if this happens on Linux when I get home today. I assume it works on Mac since that’s been tested more extensively.

Edit:
With a completely vanilla set up I can’t toggle the tree-view with ctrl + , or open the settings with Ctrl + ,

But I can find with ctrl + F or open command palette with ctrl + shift + p


#6

For anyone interested, I’ve created this pull request which will at least solve the issue on QWERTY keyboards. I’m not familiar enough with other keyboard layouts or sure this is the best end solution, but hopefully it will be a good enough stopgap until something better comes along.