Windows install requires .NET 4.5


#1

I have tried to install Atom on Windows 7 and the AtomSetup.exe displays an information window that ‘This application requires the .NET Framework 4.5’.

Is this really necessary to add a dependency on the .NET framework? Which component requires it and is it possible to skip it?

Thank you.


#2

The installer: Squirrel is built in C#


#3

So would it be possible to just download it as a .zip file or something?


#4

Yes, this is how I always update Atom as I dislike the installer. You can go to https://github.com/atom/atom/releases and download atom-windows.zip.

If you use an RSS Feed Reader you can add https://github.com/atom/atom/releases.atom to receive notifications when updates are released.


#5

Awesome :smile: TYVM!