(Windows Fix) fatal: Unable to find remote helper for 'https'


#1

I’ve been trying to install the Nuclide package all day and have been running into the stupid "unable to find remote helper for https’ message. All the google results of people having this problem have not solved my problem, and I’ve finally figured how to get mine working – so I thought I’d share.

  1. Remove Github for Windows, if you have it. Don’t forget to delete the contents of the Github folder in appdata/local and appdata/roaming.

  2. Install Git for Windows into the default location.

  3. Prepend the following to your PATH:

C:\Program Files (x86)\Git\bin;C:\Program Files (x86)\Git\libexec\git-core;

And it’ll work! (Nuclide will install, Huzzah!)

It all seems simple now, but the hard part was bruteforcing a fix – I tried all sorts of gits, path adjustments, etc, and this was the first one that worked.

Hopefully this post will save someone the headache of trying to fix their own git installation.


Publishing Package: Unable to find remote helper for 'git+https'
#2

That’s simialr to what this guy suggests on the main issue that is open for this:


#3

Interesting.

His issue is with building Atom, while mine is with installing packages that use git.

I guess it makes sense that the build env would be similar to the atom package installer environment requirements.

Additionally, atom actually prefers Github for Windows – not having git at all prompts you to install Git for Windows. Atom detected the Github portable git and tried to use it – without success. Removing it allowed apm to detect the Git for windows.


#4

Just reinstalling helped to me. Thanks!