Windows 7: file lock


#1

Hi guys,

First of all: great editor!!

But there is one really big issue (i dont know if you already noticed):

If I open a project folder (and expand them in the treeview) in atom, other programms (SourceTree, Composer …) dont have access to the folders/files.

Means, I cannot run a git checkout or a composer update without “permission denied” errors.


#2

I can’t replicate this issue.

Does it effect every file in that folder?

Are you sure it’s because of Atom? Does the folder get released after you close Atom?

If so, can you run it in safe mode (atom --safe) and see if the folder still gets locked? If not, there may be a package that does this and shouldn’t.

Finally, what’s your version? The latest released one is 124.


#3

Hi,

Problem: Open Folder/File in treeview (and or tab) results in locking.

Solution: Minimize all folders in treeview.

Version: 0.124.0

Yes

Yes

I will try to disable some plugins and send you a report then.


#4

That’s what starting Atom in safe mode (atom --safe) does. Simple way to rule out whether a package is responsible.


#5

Thats weird.

I tried to reproduce the error, but everything is fine.

I reported this “issue”, because this file locking happend to me 3 times today ( 1 time yesterday ).

The issue was, like I described above.

I will keep this thread updated if this issue happen again.


#6

If it does re-appear, maybe open the issue on the repository instead, where it can be properly tracked.

But my suspicion would be that either it was a package that meddled with your folder, or another process outside of Atom.


#7

Hello again.

Just wanted to tell you, everything went ok last days. Error doesn’t re-appear.

Case closed.


#8

Great, thanks for letting us know!


#9

Windows 10.
Directories are locked by Atom - absolutely sure.

I’m seeing it right now in Process Explorer.
It keeps open file handles to any expanded directory. When collapsed - it closes them.


#10

Windows 10.
Having the same problem. Didn’t try @DGolubets’ source for the problem in Process Explorer, but I think the problem is the same.


#11

This issue still occurs on windows 7 when a folder is expanded. Collapsing the folder unlocks the folders and subfolders.
I did start atom in safe mode, but then, where to look for a log file or a debuging window is a mystery.


#12

@raelyard, do you have any thoughts or ideas on this one?


#13

I don’t see this on Windows 10 - will need a bit of time to try Windows 7. What version of Atom are you using? To clarify, when in safe mode, are you saying that the problem does not appear (you didn’t explicitly say that but I think that’s the gist)?


#14

Found an issue that sounds the same, but has some more specific steps. https://github.com/atom/atom/issues/3365 Sounds like this is happening to you outside of any other steps, right? Any time you expand a folder in the treeview, it locks without having to run any tasks or anything else?


#15

My version is 1.2.0

Case senario : I open a project, and expand the node_modules folder. When I run a command such as npm i somemodule then I get an error. If I collapse the tree view of that folder, then I am able to run the command without any issues.
Same with some build task that require altering folders, atoms seems to lock these folders.

By safe mode I mean I run atom.exe --safe and I still get the error. In this mode I was expecting to get maybe some type of log or something somewhere to eventually see what could be causing the issue. May be it is not the vanilla Atom, but some extension that cause the issue, but how can I know ?


#16

Ok, I have reproduced this - happens on Windows 10 as well. Looks like specific to the node_modules directory. Have you seen it with any other folder?


#17

It is not constant, but it will happen also at times with our build tasks. If the tasks cleans a folder and adds files, it will fail the builds.


#18

Same here. It’s a deal breaker until this is fixed. Locking files makes it unusable for me. Shame. The UI has come a lot since the early days.


#19

Hello, I came here to report this and found this thread. I can say that in any situation when I want to write to or create files, and atom is open and in the same folder, then I consistently get permission errors. I have to close atom, do the file writing/creating and reopen atom (which works).

I don’t mind, except every time I run a build task, I have to close, build, reopen. I was using windows 7, and had this problem and recently upgraded to windows 10, and also have the same problem.

but yes to be clear, atom is clearly locking directories so that other programs and processes may not write to them.

It is for this reason, and this reason only, I have prolonged my usage of brackets which doesn’t do this. I’d love to see this get resolved, otherwise the editor is really great, and I love it to smithereens.


#20

+1 can firm happens on Windows 7 (at work) and Windows 10 (at home).