[Windows 7] DOM shadow issues on v1.0.15


#1

Hi

I’m using Windows 7, 64 bits.

Here is what I do:

  1. I download the “atom-windows.zip” file from here:
    https://github.com/atom/atom/releases/download/v1.0.15/atom-windows.zip

  2. I extract the content, so now I have an “Atom” folder containing “atom.exe” and other files.

  3. I make sure I removed the “.atom” folder in "C:\Users\MGTB8955.

  4. I run “atom.exe” (right-click “Run as Administrator” since my work computer doesn’t allow me to run it as normal user)

  5. I click on “File / Open your stylesheet”

  6. I uncomment the line: “border-color: red;” and save the file

  7. At this point, the cursor should immediately turn red. It does not!

  8. I close Atom

  9. I run “atom.exe” again (still “Run as Administrator”). Now the cursor is red for like 10 seconds, and goes back to default color.

This seems to be a DOM shadow issue or something like that. I noticed that all the settings I put in “styles.less” were loaded when Atom was run, then they were overwritten by the “One Dark” theme (“One Dark” is set on both UI and Syntax theme).
Moreover, once the settings from “styles.less” have been overwritten, it’ is not possible to open a file anymore.

v1.0.8 was working great on the same computer.

EDIT: I copied the whole “Atom” folder in “C:\Program Files (x86)” so I am able to run it as normal user. Still the exact same issues. However here is what I’ve got:


#2

I’m not sure what the EMFILE: Too many open files message is about. But that would seem to be the cause of the issue.

What happens if you use the Atom installer? Or can you not do that since this is a work computer?


#3

Indeed I can’t test that because of the corporate proxy :unamused:

EDIT: probably a related issue: https://github.com/atom/atom/issues/8882


#4

Yes, it does look like the same issue.


#5

This seems to be the problem: