Windows 7 - Corporate Laptop - issue with package install


#1

Im having some issues with installing a package - I wanted to install the Activate-Power-Mode package cus it looked kinda cool.

Firstly I can’t install through atom - I get
Searching for “activate-power-mode” failed.Hide output…
tunneling socket could not be established, statusCode=407

I’ve tried setting the strict ssl - No dice.

So - manual install - I downloaded the full git - got me activate-power-mode-master - which I unzipped to C:\Users\my.user.atom\packages

I Then CD to the dir - CD C:\Users\my.user.atom\packages\activet-power-mode-master - I ran apm link and apm install:

PS C:\Users\my.user.atom\packages\activate-power-mode-master> apm link
C:\Users\my.user.atom\packages\activate-power-mode -> C:\Users\my.user.atom\packages\activate-power-mode
-master

(that was all the output I got for the apm link)

PS C:\Users\my.user.atom\packages\activate-power-mode-master> apm install
Installing modules done

When I loaded atom - The module was there, for sure, but I can’t edit the settings - The setting button takes me to the package info - but I can’t change things such as

Auto Toggle
Auto enable power mode on atom start.

Combo Mode
Enable/Disable

When enabled effects won’t appear until reach the activation threshold.

Activation Threshold
Streak Timeout
Exclamation Every
Exclamation Texts

Screen Shake

Enable/Disable
Intensity

SO - I deleted the folders and tried installing via powershell - which was also successful (or seemed to be)

PS C:\Users\my.user.atom\packages\activate-power-mode-master> apm install activate-power-mode

stayed blank for a moment, then returned to my prompt - no error or anything - Checked the folder and the Activate-power-mode folder was there with the files - Opened Atom - Package NOT there - somehow does not seem to be installed.

if I go into the actiate-power-mode folder and run apm install again - I can get it on atom - BUT I cannot do anything with it, I can’t even activate it.

I’m not sure where I’m going wrong, but I’m totally stuck as to what to do :confused:

Help would be greatly appreciated - pleasse - all I want to do is change the freaking settings on the package!!!


#3

This sounds like it might be a proxy issue. Do you use NPM? APM is modeled on NPM, so my expectation would be that a machine that has connectivity trouble with one would also have problems with the other.

So - manual install - I downloaded the full git - got me activate-power-mode-master - which I unzipped to C:\Users\my.user.atom\packages

I’m not 100% sure that this is the reason behind your troubles, but the contents of the packages/ directory are what Atom looks at to identify the packages you have installed, and at the moment you have one package taking up two folders. You should delete the link and remove -master from the main one, then restart Atom (don’t just reload the window) and see if it works better. I would suggest storing packages you manually install under a directory such as github/atom, should you choose to do so again (this is usually done when developing packages, and there’s a shortcut with apm develop).

Additionally, you can tell APM to install directly from the GitHub repo, with apm install JoelBesada/activate-power-mode. If your connectivity issue is with the APM database, and the program itself (and its NPM backbone) are functioning for you, this should work.

I can’t edit the settings

Are you able to edit the settings of other packages?


#4

My apologies for a late response.

First of all - Open honesty - I’m very new to using atom - and I no nothing about how Github works etc. which makes alot of stuff surrounding atom difficult for me to understand.

I’m not sure how, but the settings have become editable for me now - I spent alot of time messing with it, I think I installed it from powershell with apm install - No errors. But I remember I still wasn’t able to edit the settings within atom initially.

I had been making changes to the coffee file to change the settings, but I noticed today, that I can now edit the settings insite atom, not sure what I did (if it was me directly) that caused this to work, but its working.

At the time, there were other packages that I could edit - But these were all the pre installed ones.

Either way, I thank you for your response and apologise for wasting time.

~ Dark


#5

What specifically are you having trouble with?


#6

Ultimately, I was just having trouble with changing the settings for the Activate-power-mode package - But when I came to my laptop the other day, I noticed that I could now edit the settings, not sure what changed. I had rebooted and reloaded atom etc. after installing the package to no avaial.

So I can’t say for certainty what it was that opened up the settings for me, but the issue has been resolved.

I just don’t get how the gitpackages work, forking repoisotires, pull requests. these words all mean nothing to me lol. maybe I just got in over my head, but everything is okay now :slight_smile:

Thanks for you

~Dark


#7

I think you’re reading too much into this. At no point in this thread have I mentioned anything about forking a repo or submitting a pull request. It’s most convenient to clone packages you plan on installing manually, but the difference between cloning and just downloading it is not important unless you plan on using git’s features.