[Windows 7] Atom builds but doesn't appear under Program Files


#1

Hi everyone,

I previously had atom built and running on my system then I decided to delete and rebuild it. I started by deleting the atom directory under Program Files as well the atom project. I cloned a new copy of atom and ran script/build. After the build completes, there is no atom directory under the Program Files directory and no atom executable files created. Does anyone know what could be the issue?

Here is my console output after atom builds:

C:\atom [master]> script/build
npm WARN package.json github-url-from-git@1.1.1 No repository field.

Installing modules √
Installing atom-dark-syntax@0.15.0 √
Installing atom-dark-ui@0.26.0 √
Installing atom-light-syntax@0.17.0 √
Installing atom-light-ui@0.24.0 √
Installing base16-tomorrow-dark-theme@0.15.0 √
Installing solarized-dark-syntax@0.14.0 √
Installing solarized-light-syntax@0.7.0 √
Installing archive-view@0.31.0 √
Installing autocomplete@0.28.0 √
Installing autoflow@0.17.0 √
Installing autosave@0.13.0 √
Installing background-tips@0.13.0 √
Installing bookmarks@0.22.0 √
Installing bracket-matcher@0.38.0 √
Installing command-palette@0.21.0 √
Installing deprecation-cop@0.5.0 √
Installing dev-live-reload@0.30.0 √
Installing exception-reporting@0.17.0 √
Installing feedback@0.33.0 √
Installing find-and-replace@0.106.0 √
Installing fuzzy-finder@0.52.0 √
Installing git-diff@0.28.0 √
Installing go-to-line@0.21.0 √
Installing grammar-selector@0.27.0 √
Installing image-view@0.33.0 √
Installing keybinding-resolver@0.18.0 √
Installing link@0.22.0 √
Installing markdown-preview@0.72.0 √
Installing metrics@0.32.0 √
Installing open-on-github@0.28.0 √
Installing package-generator@0.30.0 √
Installing release-notes@0.31.0 √
Installing settings-view@0.116.0 √
Installing snippets@0.43.0 √
Installing spell-check@0.35.0 √
Installing status-bar@0.40.0 √
Installing styleguide@0.29.0 √
Installing symbols-view@0.54.0 √
Installing tabs@0.40.0 √
Installing timecop@0.18.0 √
Installing tree-view@0.93.0 √
Installing update-package-dependencies@0.6.0 √
Installing welcome@0.14.0 √
Installing whitespace@0.22.0 √
Installing wrap-guide@0.18.0 √
Installing language-c@0.15.0 √
Installing language-coffee-script@0.22.0 √
Installing language-css@0.16.0 √
Installing language-gfm@0.38.0 √
Installing language-git@0.9.0 √
Installing language-go@0.12.0 √
Installing language-html@0.22.0 √
Installing language-hyperlink@0.9.0 √
Installing language-java@0.10.0 √
Installing language-javascript@0.26.0 √
Installing language-json@0.8.0 √
Installing language-less@0.9.0 √
Installing language-make@0.10.0 √
Installing language-objective-c@0.11.0 √
Installing language-perl@0.8.0 √
Installing language-php@0.14.0 √
Installing language-property-list@0.7.0 √
Installing language-python@0.17.0 √
Installing language-ruby@0.25.0 √
Installing language-ruby-on-rails@0.14.0 √
Installing language-sass@0.11.0 √
Installing language-shellscript@0.8.0 √
Installing language-source@0.7.0 √
Installing language-sql@0.8.0 √
Installing language-text@0.6.0 √
Installing language-todo@0.10.0 √
Installing language-toml@0.12.0 √
Installing language-xml@0.14.0 √
Installing language-yaml@0.6.0 √
Deduping modules √
Running "download-atom-shell" task
C:\atom [master]>

Running the build process results in:

C:\atom [master]> script/build

Removing envify √
Installing modules √
Deduping modules √
Running "download-atom-shell" task

Running "build" task
Aborted due to warnings.

Thank for your time.


#2

Hello,

I’ve the same problem on Windows 8.1 (with the same console output).
Everything went fine but at the end no atom folder in Program Files. I tried several searchs on my hard drive but didn’t manage to find an atom.exe, except the one to launch shell app (located at C:\atom\atom-shell\atom.exe ).

So I installed the latest build from this source (http://atom.someguy123.com/#sthash.gYcEAkjj.OAgnGGWA.dpbs).


#3

Same problem W7

C:\Users\Marcelino\Documents\GitHub> cd C:\
C:\> git clone https://github.com/atom/atom/
Cloning into 'atom'...
remote: Reusing existing pack: 100706, done.
remote: Counting objects: 16, done.
remote: Compressing objects: 100% (16/16), done.
remote: Total 100722 (delta 6), reused 0 (delta 0)
Receiving objects: 100% (100722/100722), 238.99 MiB | 120.00 KiB/s, done.
Resolving deltas: 100% (70322/70322), done.
Checking connectivity... done
C:\> cd atom
C:\atom [master]> script/build
You must have Python 2.7 installed at 'C:\Python27\'
C:\atom [master]> script/build
npm WARN package.json github-url-from-git@1.1.1 No repository field.
npm ERR! fetch failed https://registry.npmjs.org/graceful-fs/-/graceful-fs-2.0.3
.tgz
npm ERR! fetch failed https://registry.npmjs.org/lru-cache/-/lru-cache-2.5.0.tgz

npm ERR! fetch failed https://registry.npmjs.org/underscore.string/-/underscore.
string-2.2.1.tgz
npm ERR! fetch failed https://registry.npmjs.org/readable-stream/-/readable-stre
am-1.1.13-1.tgz
npm WARN package.json github-url-from-git@1.1.1 No repository field.

Installing modules done
Installing atom-dark-syntax@0.15.0 done
Installing atom-dark-ui@0.29.0 done
Installing atom-light-syntax@0.17.0 done
Installing atom-light-ui@0.25.0 done
Installing base16-tomorrow-dark-theme@0.15.0 done
Installing solarized-dark-syntax@0.14.0 done
Installing solarized-light-syntax@0.7.0 done
Installing archive-view@0.31.0 done
Installing autocomplete@0.28.0 done
Installing autoflow@0.17.0 done
Installing autosave@0.13.0 done
Installing background-tips@0.14.0 done
Installing bookmarks@0.22.0 done
Installing bracket-matcher@0.41.0 done
Installing command-palette@0.21.0 done
Installing deprecation-cop@0.6.0 done
Installing dev-live-reload@0.31.0 done
Installing exception-reporting@0.18.0 done
Installing feedback@0.33.0 done
Installing find-and-replace@0.111.0 done
Installing fuzzy-finder@0.54.0 done
Installing git-diff@0.28.0 done
Installing go-to-line@0.22.0 done
Installing grammar-selector@0.27.0 done
Installing image-view@0.33.0 done
Installing keybinding-resolver@0.18.0 done
Installing link@0.22.0 done
Installing markdown-preview@0.73.0 done
Installing metrics@0.32.0 done
Installing open-on-github@0.28.0 done
Installing package-generator@0.30.0 done
Installing release-notes@0.31.0 done
Installing settings-view@0.117.0 done
Installing snippets@0.44.0 done
Installing spell-check@0.35.0 done
Installing status-bar@0.40.0 done
Installing styleguide@0.29.0 done
Installing symbols-view@0.54.0 done
Installing tabs@0.41.0 done
Installing timecop@0.19.0 done
Installing tree-view@0.95.0 done
Installing update-package-dependencies@0.6.0 done
Installing welcome@0.16.0 done
Installing whitespace@0.22.0 done
Installing wrap-guide@0.18.0 done
Installing language-c@0.15.0 done
Installing language-coffee-script@0.22.0 done
Installing language-css@0.16.0 done
Installing language-gfm@0.38.0 done
Installing language-git@0.9.0 done
Installing language-go@0.12.0 done
Installing language-html@0.22.0 done
Installing language-hyperlink@0.9.0 done
Installing language-java@0.10.0 done
Installing language-javascript@0.26.0 done
Installing language-json@0.8.0 done
Installing language-less@0.9.0 done
Installing language-make@0.10.0 done
Installing language-objective-c@0.11.0 done
Installing language-perl@0.9.0 done
Installing language-php@0.14.0 done
Installing language-property-list@0.7.0 done
Installing language-python@0.17.0 done
Installing language-ruby@0.26.0 done
Installing language-ruby-on-rails@0.14.0 done
Installing language-sass@0.11.0 done
Installing language-shellscript@0.8.0 done
Installing language-source@0.7.0 done
Installing language-sql@0.8.0 done
Installing language-text@0.6.0 done
Installing language-todo@0.10.0 done
Installing language-toml@0.12.0 done
Installing language-xml@0.14.0 done
Installing language-yaml@0.6.0 done
Deduping modules done
Running "download-atom-shell" task
C:\atom [master]>

#4

Run the build process again and this time it will add everything in the right place including start menu.


#5

You’re right, I run node scripts/build again, and it added the folder in C:\Program Files\Atom plus a shortcut on my desktop :slight_smile:

If you’re on Windows 8/8.1, you can add Atom to the Program Start Screen (in Metro UI) by adding the shortcut to C:\ProgramData\Microsoft\Windows\Start Menu\Programs