Windows 10 launches in terminal shell but not in GUI

I just installed Atom on Windows 10 a few days ago. Suddenly, out of the blue, I got this when trying to launch Atom from the normal Windows 10 Start Menu:

image

I started looking through the Troubleshooting documentation, and saw that I should disable packages, comment out the init script, etc. etc.

But then I noticed something: when I start atom from a terminal, everything is fine! I don’t even start it in safe mode. I just write “atom” and that’s that. Everything works as though there were never a problem. But then going back to the Windows Start Menu, once again I get that error message.

What might be going on here?

Thanks,

John

As a test:

  • Navigate to the executable file
    C:\Users\John\AppData\Local\atom\atom.exe
  • Alt with drag and drop to the desktop a shortcut
  • Open the desktop shortcut

What is the result?

If this works for you, delete the start menu shortcut that is there now.
Right click on the executable file and request to pin to the start menu.

First of all, thanks for responding so quickly, much appreciated!

Bad news and good news: I did the navigation you suggested, and tried it. Same result.

Good news: I noticed that atom.exe appears in THREE places. The place where you indicated, but also in …\atom\app-1.40.1 and in …\atom\app-1.41.1. (On my installation, of course.)

I tried both of those, too. In app-1.41.0 it didn’t work either. But in app-1.40.1 it DID work just as you suggested.

So, being a total newcomer to atom, my guess is something like: the folder you indicated is somehow a “pointer” to one of the app-1.4x folders. The app-1.41.0 folder seems to be screwed up / corrupted, whatever – and the other one is okay.

I pinned the one that worked to the taskbar and for now, at least, everything seems to work. So once again THANK you. And of course as I learn about atom I’ll probably eventually understand what it actually was that got messed up. - John

I am of the opinion that your Atom was updated automatically and that something went wrong. What you have done now is the equivalent of reverting to the previous version. That is not much of an issue - working with V1.40 instead of V1.41.

Personally I have not experienced such a problem. But I have opted to manually update from resources found on https://github.com/atom/atom/releases/.

Consider the following actions:

  1. Copy the contents of ..\AppData\Local\atom to another location (thumb-drive / hdd).
  2. Delete the ..\AppData\Local\atom folder.
  3. Install the Atom application from https://github.com/atom/atom/releases/.
  4. Test the application.
  5. Choose to restore the backed up files or keep as insurance.

Find the file-hash below to verify your downloaded

Windows PowerShell
Copyright (C) Microsoft Corporation. All rights reserved.

D:\>Get-FileHash AtomSetup-x64-1.41.0.exe                                                                               
Algorithm       Hash                                                                   Path
---------       ----                                                                   ----
SHA256          7B1CA4D7521BFBB581F7A8A599A63C7E8F1EB221AD895059A4D6CFB912134777       D:\AtomSetup-x64-1.41.0.exe

Your analysis makes perfect sense.

I did exactly what you recommended, and the newly installed 1.41 version works perfectly now also from the Start Menu launcher.

I also followed your suggestion to update manually in the future, and unchecked the option for automatic updates.

Thanks once again for everything!

John