Windows 10 Add Selection Keyboard Shortcuts (Ctrl+Alt+Arrows) Not Working


#1

Sorry if this has already been covered, I couldn’t find anything with a quick search.

Essentially, the default key bindings for Add Selection Above/Below are Ctrl+Alt+Up Arrow and Ctrl+Alt+Down Arrow (or Alt+Ctrl+Up Arrow and Alt+Ctrl+Down Arrow as the application incorrectly suggests :wink: ), and they aren’t working.

I used the Ctrl+. shortcut to see the key binding resolver and it is only seeing Ctrl+Alt and not the arrow it would appear.

Having looked at this page it suggests that windows magnifier uses these key bindings for panning.

But I don’t have that loaded and I’m not sure what else might be stopping it from arriving with Atom.

Any feedback anyone has greatly appreciated. Thanks.


#2

This is an indication that something is intercepting that key combination before Atom can “see” it. If it isn’t the Windows Magnifier, then it is something else. Unfortunately, there isn’t a good way to determine what is keeping Atom from seeing this key combination :frowning2:


#3

Thanks. Yes, that’s what I suspected.

I kept digging and apparently I’m using an Intel graphics adapter in this laptop.

I hit Ctrl+Alt+F12 which opened the panel for it – this indicated that hot-keys were enabled for my Intel HD Graphics Control Panel.

After going into Options and Support, I selected Disable under Manage Hot Keys and applied the configuration.

Since then, it’s all working perfectly :grin:

Now I just don’t have hotkey access to my graphics adapter! Honestly, I don’t think that’s going to be a problem and quite frankly, I think that should be disabled by default.

Anyway, thanks again.
D.