Window not responding, I need to restart computer


#1

Hi, after 15-30 mins of using Atom, window freezes and not responding, after that i can’t open Atom. I need to restart computer, to use Atom again. This has started to happen a few days ago, before that I used Atom 4-5 months and everything worked really good. I try with “safe mode” and with some other solutions but with no luck. This happens on all kind of files(css,js,php…) on local server or not.

OS: win7/64bit
Atom: v1.3.1 (updated today, from 1.2.7)


#2

Try this:

  1. Close all instances of Atom
  2. Delete or move $HOME\.atom\storage
  3. Launch Atom again from the command line using atom --safe

#3

I’m seeing this as well on Mac OS (10.11.1)

  • 1.2.x was rock solid
  • Installed 1.3.1
    • Near instafreeze
  • Deleted contents of ~/.atom/storage, ~/.atom/blob-store, ~/.atom/compile-cache
  • Started in safe mode
  • Complete lockup when opening about the 5th file (small 20 line files)
  • Nothing shows up in the log in the developer tools

EDIT - Just tryed the 1.4.0 beta, problem gone. Guess I’ll stick to beta channel now :stuck_out_tongue:


#4

We’re going to look into this. If there is any more information you can give as to what might be going on, please let us know.


#5

I did the 1-2-3 step. I worked in Atom about 25-30 mins, then the inner Atom window just froze. I had access to Atom menu (file, edit, view…) but not to the inner window (tabs, current open file). I closed Atom and repeated 1-2-3 step, Atom is opened (I did not have to reset comp) and everything looks fine, until I try to open the last opened file, it freezes again. Atom opens all files, except that last active file. When I try to open that file from os window “right click>open with atom”, os window freezes and not responding (only on that file!).

Warning when Atom is launched.


#6

What is “the 1-2-3 step”?

And those warnings aren’t an indicator of Atom’s health. They’re deprecation warnings from Chromium.


#7

1 - Close all instances of Atom
2 - Delete or move $HOME.atom\storage
3 - Launch Atom again from the command line using atom --safe


#8

What is different about that one file?


#9

That is js/angular file(100 lines of code), that file was open when I back from Firefox to Atom.
It looks as if the file is remembered somewhere in Atom memory and when i try to open that file (again), Atom starts to bugging… When I restart computer, everything is back to normal.


#10

Here’s the file in the repo that crashes Atom 1.3.1 for me: https://github.com/JustinAiken/pi2_ansible/blob/master/roles/openhab_server/tasks/main.yml

Even after a restart, cache-clearing, and opening in safe mode…

Fortunately, the 1.4.0beta0 is the most stable Atom I’ve used yet, so… :smile:


#11

I updated Atom(1.4.0-beta) and Nodejs but still crashing… even in the safe mode…


#12

hi,
I have same problem.
I using Atom about 15-30 mins, Atom not responding, after that i can’t open Atom. I need to restart computer, to use Atom again.
i tried close all instances of Atom in Task Manager and remove $HOME.atom\storage
But it not work.
Please help me fix it.

OS: win 7 32
Atom: v1.3.1 or 1.4.0 beta 3