Win7 clang and console charset


#1

Trying clang cpplint on win7. Having error in console:

activate linter-clang
G:\atom\.atom\packages\linter-cpplint\lib\init.coffee:22 activate linter-cpplint


G:\atom\.atom\packages\linter-clang\lib\linter-clang.coffee:187 linter-clang: is node executable: false
G:\atom\.atom\packages\linter-clang\lib\linter-clang.coffee:218 linter-clang: command = G:/_dev/cxx/llvm/bin/clang.exe, args = C:\Users\A1\AppData\Local\Temp\AtomLinter115314-6436-cf7010source.cpp\1.cpp,-fsyntax-only,-fno-caret-diagnostics,-fno-diagnostics-fixit-info,-fdiagnostics-print-source-range-info,-fexceptions,-xc++,-Wall,-std=c++11,-ferror-limit=0,-IC:\Users\A1\Desktop, options = [object Object]
clang: stderr ������ "G:\_dev\cxx\llvm\bin\clang.exe" �� ᮢ���⨬� � ���ᨥ� Windows, ࠡ����饩 �� �⮬ ����������. �஢����� ᢥ����� � ���⥬�, �⮡� 㧭���, ����� ������ �ணࠬ�� x86 (32-ࠧ�來��) ��� x64 (64-ࠧ�來��) ��� �㦭�, � �������� �� � ���⠢騪� �ணࠬ����� ���ᯥ祭��.

How can I set up cyrilic chars in dev console?
What about clang?


#2

What dev console are you talking about here? I don’t recognize the command or the output …


#3
  1. View - developer - open in dev mode.
  2. View - developer - Toggle developer tools. There is console.

Only in dev mode you can find logs of linter-clang process.

upd…
Reread my first message. Understand its unclear. So… I trying to use clang cpplint in atom. Nothing happens when I run lint command on cpp file. Open my cpp file in dev mode and look console. There is such chinesse symbols and clang stderr.


#4

I think you’ll want to open an issue on the repository of the linter-clang package.
Whoever maintains that package might be able to explain what you’re seeing, and perhaps can help you.


#5

Ok, cpplint is an issue of cpplint.
And what about console? How to make it show propper cyrillic symbols? Console is an atom thing.


#6

What’s the font family you’re using on your Windows system and the font in Atom Settings?


#7

In settings font family field is empty.