Win 7 x64 build issue


#1

Hello! Trying to build atom. Made everything according to manual and even more with remarks from Installation issue on Windows and after that having such error log:

npm WARN package.json github-url-from-git@1.1.1 No repository field.
gypnpm ERR! git-utils@1.3.0 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!

npm ERR! Failed at the git-utils@1.3.0 install script.
npm ERR! This is most likely a problem with the git-utils package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-gyp rebuild
npm ERR! You can get their info via:
npm ERR!     npm owner ls git-utils
npm ERR! There is likely additional logging output above.

npm ERR! System Windows_NT 6.1.7601
npm ERR! command "node" "c:\\Users\\A\\github\\atom\\build\\node_modules\\npm\\b
in\\npm-cli.js" "--userconfig=c:\\Users\\A\\github\\atom\\.npmrc" "install" "--q
uiet"
npm ERR! cwd c:\Users\A\github\atom\apm
npm ERR! node -v v0.10.28
npm ERR! npm -v 1.4.10
npm ERR! code ELIFECYCLE
npm

#2

This is extremely strange. I haven’t had this issue.

One thing to note is that when building on Windows, most errors are fixed by repeating the build process several times. Can you please re-run script\build and confirm the error persists?

Some other details we’d need to know would include which Visual Studio version you’re using, where you got your Git from (run git --info-path and it’ll tell you where your git install is coming from), and which version of python you’re using python -V

I’m unsure why you’re getting this problem when I recently built Atom using the build instructions on a fresh install recently, with no problems whatsoever.


#3

Correcting info:

git --info-path:

C:\Users\A\AppData\Local\GitHub\PortableGit_054f2e797ebafd44a30203088cd3d58663c6
27ef/share/info

python

Python 2.7.6 (default, Nov 10 2013, 19:24:24)

MSVC: firstly I used vs2010 express (no result), than I found here Unable to build Atom on Windows 8.1 to setup windows sdk and remove msvc 2010 redistrib. It helped me to reinstal runas package to node.js and solve some mistakes (connected with runas), but this mistake isn’t solved.

Node.js: latest win32 release.

And of course I tried several times to run script/build


#4

This is strange, it all seems to check-out properly.

Here’s what my Windows 8 build server has:

C:\Users\Dev\Documents\GitHub\atom>git --info-path
C:\Users\Dev\AppData\Local\GitHub\PortableGit_054f2e797ebafd44a30203088cd3d58663c627ef/share/info

C:\Users\Dev\Documents\GitHub\atom>node -v
v0.10.28

C:\Users\Dev\Documents\GitHub\atom>npm -v
1.4.9

Also, I’ve built successfully using both VS2010 (the premium version), and VS2010 C++ express on my build server, plus my home builds are done with Git4Windows while my server builds are with Github’s App PortableGit so I don’t think your Git version is an issue.
I don’t understand why you’re getting complaints about git-utils.


#5

Yes, I got the same problem. I am using the exact the same version described in github.com/atom/atom/blob/master/docs/build-instructions/windows.md and tried several times,


#6

I found solution. These steps need to do:

  1. Make sure, that you have SP1 update to vs2010 (important!!!). I used express edition.
  2. Make sure you installed runas via microsoft windows sdk (see here Unable to build Atom on Windows 8.1)
  3. Try to rename cvtres.exe to cvtres_old.exe in "c:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin\ " They say it helps sometimes.
  4. Make sure "c:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin\ ", python, gitcmd, node.js in System PATH. Also add to PATH “C:\Users…\github\atom\build\node_modules”

#7

SP1 is key, after upgrading to SP1 (without nothing else changes), it works.
Thanks a lots.


#8

I had same error. but I maybe forgottena to add to PATH “C:\Users…\github\atom\build\node_modules”

added and retry, successed.

By the way, I built with VS2013 Express for Desktop.