Why the "Open Folder" does not work properly?


#1

Hi,

I would like to know if I need to do something else to make the “Open Folder” option work like a “Open workspace”. All my projects are inside a project folder and I cannot see the difference when using “Open Folder” because the project folder (root one) is already open.

I was hoping to find an option close to the one in other editors (like in Sublime Text or Brackets). There, whe you use “Open Folder” it treated this folder as the root. For me this is a nice feature that allows to separate workspaces.

Am I missing something? I was hoping to see a tutorial but I think this feature is not implemented in that way. Maybe an extension?

There is also that annoying feature of showing even the dot files of the home directory (linux). I think the file explorer needs to be separated from the working directory approach.

Thanks in advance


#2

If you’re talking about having more than one “root” folders, you can use the context menu for that.
Right-click somewhere on the tree view, and choose “Add Project folder”, and select which folder you want to add to the tree view.


#3

Thank you for the response. I’ve tried to do what you suggested. But each time I use that option (“Add project folder”) it includes all my home folder. I tried removing the folder from the project, and do it again, but it always include all my home folder. And if I try to include another folder, it does nothing (because I think it is not able to add an existing folder).

I have removed and installed atom several times. I have erased the cache left in my configuration directory. Nothing seems to change.

I am using Ubuntu 12.04.5, maybe a library is outdated in my system?

I’ve tested atom in Windows 8 and there the behavior seems ok. So I guess is something in my system.


#4

You mean this does not work for you?

I’ve tried it on Windows and also on my Ubuntu laptop and I have no issues.

Can you try running Atom in safe mode (atom --safe) and see if it still won’t work?
If it does not, open an issue on the tree-view repo.


#5

Hi,

I’ve tried what you suggested in your animation, and also using atom --safe but nothing happens. That option always opens my home folder no matter what I select.

In windows 8 it works properly, in Ubuntu 12.04.5 it does not work.

I will open a ticket as you suggested.


#6

I’m having the same problem, did you ever get that fixed?


#7

Im having same problem, but then I tried to make my project folder and it subs permission to least 777. It works well for me now .