Why the "autocomplete-paths" just doesn't work


#1

I have installed that packages yet, but it doesn’t work. Is there any other config need to be done? I thought the description of that package is too short, resulted a lot of problem to me


Autocomplete-paths 2.0: Automatic path suggestions
#2

What operating system are you running and what are you typing that you believe should result in a path autocompletion being offered?


#3

I can confirm that this package does not work for me on Atom V1.18 on Windows7. autocomplete-plus was already installed before installing this package.

I tried to starting to type in Coffeescript text:
Hello = require "./"
Starting with “./” or “.\” does not work, Javascript is also not working.

- Dan Padric


#4

Windows paths use backslashes. Start with .\.


#5

Hi.

I corrected my answer now to the correct notation.
The short of it is - neither ./ nor .\ works.
Do you use this package?.. could you please try it?

Thank you.


#6

I do, and it works for me. It doesn’t make any suggestions until I start typing letters, so if I type \g, it will suggest to me D:\github.


#7

Perhaps you have some configuration inside autocomplete-plus or another package that helps for this. On my system it does not work.


#8

You can see that autocomplete-paths doesn’t have any configurations, and I haven’t changed autocomplete-plus at all.


#9

So this one sounds like a :beetle:


#10

Could be. It’s hard to tell until it’s being replicated.


#11

>> Surely you mean until you have replicated it.
:confused: (I have already replicated it on my Window7 machine.)


#12

That’s not a replication. A replication involves simulating the environment in which aberrant behavior occurs in order to make the bug happen on command. We have no information about @hapulb’s situation, so that can’t be replicated, and I don’t have the ability to test on Windows 7 (I don’t even know where to find a Windows 7 computer any more).


#13

What I am hearing is - n00bs cannot be helpful to designers for finding issues as there are no procedures they can follow to give helpful feedback to the designers of the system / package. The situation is worse when they use antique OS systems that is only ‘supported’ in name.

:frowning_face: (Sorry for trying to be helpful.)


#14

Not at all. The procedure is to share as much information as you can on the relevant GitHub repo and see if somebody can make the bug happen on their own system.

The situation is worse when they use antique OS systems that is only ‘supported’ in name.

This is normal when using old operating systems. If you’re using a commercial program, they’ll have people on staff who can test it on all platforms it runs on, but with open source projects, nobody’s going to pay to keep an out-of-date machine operational just to test edge case bugs with community packages.

We don’t even know for sure that it’s your OS, but your OS is the only variable that you have made me aware of.


#15

Hey there, today I released autocomplete-paths version 2, which fixes all these issues. Go check it out! :slight_smile:


#16

SYSTEM: Windows 7 SP1 64-bit | Atom V1.19 | autocomplete-path V2.3.0

Hi.

The ‘original’ version 2.0.0 did not work for me.

You have identified some possible issues and reworked code (thank you!!). I tried V2.3.0. This does not work for me either. The installation this time goes through without being aborted like last time. BUT then…

  1. the Atom environment reports of updating the path cache.
  2. after a long while my OS reports that Atom is not responding.

Waiting longer for Atom to respond, does nothing. Open and closing does nothing to help. Uninstalling the package is a problem too. Force deleting of files from the package directory does not work - files are locked.

I used Windows Safe mode to reach the files in the package directory and wipe the “autocomplete-path” package.

These notes above is as feedback. It is not important to me to have this package working on my system… so there is no emotion (like anger) coupled with it.

My sincere thanks efforts and your time given freely to our community.
(sarcasm := VOID)

Good luck with further development.
Cheers.


#17

That’s so weird, as it only happens to Windows users yet. I’ll investigate when I have access to a windows machine. Thanks a lot for the detailed report!


#18

Does it have something to do with which switch we use… / vs \? The coding for Atom API (coffeescript / javascript) and Python I can say does not worry about me using /. I use the / in Python, else I have to use \\ to indicate the single \ in a string.

I would not blame you to iron out functionality for Linux and Apple to later return to Windows. All I can say - good luck.


#19

Did you save the file?

Allow my to be nitpicky for a second: That’s a myth that will probably never go away. Yes, it’s common to use back-slashes on Windows, which goes back to MS-DOS, which stole it from CP/M. Technically, about every Windows API supports forward-slashes interchangebly (and I read unconfirmed rumours that MS-DOS did this as well!)

Anyway, the latest version of autocomplete-paths throws the same error on both, macOS 10.12 and Windows 10, regardless whether I write JavaScript or CoffeeScript.

macOS, using Atom 1.19:

TypeError: Cannot read property 'path' of null
    at PathsProvider._getSuggestionsForScope (/Users/jan/.atom/packages/autocomplete-paths/lib/paths-provider.js:121:65)
    at /Users/jan/.atom/packages/autocomplete-paths/lib/paths-provider.js:211:12
    at Array.map (native)
    at PathsProvider.getSuggestions (/Users/jan/.atom/packages/autocomplete-paths/lib/paths-provider.js:210:30)
    at /Applications/Atom.app/Contents/Resources/app/node_modules/autocomplete-plus/lib/autocomplete-manager.js:337:60
    at Array.forEach (native)
    at AutocompleteManager.getSuggestionsFromProviders (/Applications/Atom.app/Contents/Resources/app/node_modules/autocomplete-plus/lib/autocomplete-manager.js:313:23)
    at AutocompleteManager.findSuggestions (/Applications/Atom.app/Contents/Resources/app/node_modules/autocomplete-plus/lib/autocomplete-manager.js:302:25)

Windows 10, using Atom 1.18:

TypeError: Cannot read property 'path' of null
    at PathsProvider._getSuggestionsForScope (file:///C:/Users/jan/.atom/packages/autocomplete-paths/lib/paths-provider.js:121:65)
    at file:///C:/Users/jan/.atom/packages/autocomplete-paths/lib/paths-provider.js:211:12
    at Array.map (native)
    at PathsProvider.getSuggestions (file:///C:/Users/jan/.atom/packages/autocomplete-paths/lib/paths-provider.js:210:30)
    at C:\Users\jan\AppData\Local\atom\app-1.18.0\resources\app\node_modules\autocomplete-plus\lib\autocomplete-manager.js:337:60
    at Array.forEach (native)
    at AutocompleteManager.getSuggestionsFromProviders (C:\Users\jan\AppData\Local\atom\app-1.18.0\resources\app\node_modules\autocomplete-plus\lib\autocomplete-manager.js:313:23)
    at AutocompleteManager.findSuggestions (C:\Users\jan\AppData\Local\atom\app-1.18.0\resources\app\node_modules\autocomplete-plus\lib\autocomplete-manager.js:302:25)

#20

OFF TOPIC

Mr. Jan, I am unsure how to respond to your question / suggestion. My response is not helping the current subject, but confirms I have read your what you said.

The purpose of my original description was to put in words the steps I followed where I expected the autocomplete-path to trigger with a suggestion. It is like typing if and expecting autocomplete to pop up with a suggestion for a full written out if-statement.

The package did not respond as I expected it to - when I wrote the first notes. Currently the package does not even install on my system. So much you confirmed too (thank you).

May I just say, I value your participation and insights. If you have some tips from your experience to share with the author on how to overcome this current hurdle; it would be warmly welcomed.

Beste wensen
- Dan