Why keybindings'ctrl-alt-up/down' not work?


#1

I’d like to do some ‘Add Selection Above/Below’, I’ve check the setting, and make sure the keybindings are ‘ctrl-alt-up/down’. But nothing happens while I press these keybindings.

My keymap fils is empty.

Atom: 1.05
OS: Windows 7 Pro


#2

Have you tried using the Keybinding Resolver (Cmd+. on OS X and Ctrl+. on other platforms)? It will show you what key Atom saw you press and the command that was triggered because of it.


#3

Hi leedohm, just tried the Keybinding Resolver.

When I hold ‘ctrl-alt-up’ together, the Keybinding Resolver only shows ‘ctrl-alt’, it seems that atom can NOT recognize the ‘up’ or ‘down’ or ‘left’ or ‘right’ keys when ‘ctrl’ and ‘alt’ are holded.

And I tried ‘ctrl-alt-pageup’ or ‘ctrl-alt-pagedown’ or other keys with ‘ctrl-alt’, the Keybinding Resolver can recognize these keystrokes correctly.

Atom: 1.05
OS: Windows 7 Pro
Laptop: Dell E7240


#4

It sounds like something on your computer has registered CTRL+ALT+UP/DOWN as a global hotkey. A common offender is the Intel HD Graphics control panel (often found in your system tray).


#5

I have already disabled the hotkey function of the Graphics :frowning:


#6

If the OS is not sending the keystrokes to Atom, which is almost assuredly what is indicated when Atom doesn’t show those keystrokes in the Keybinding Resolver, then there really isn’t much Atom can do.

What keyboard layout are you using? Could you be running into this?


#7

OK, I find a way to deal with this issue now.

I’ve just change the hotkey setting of the Intel HD Graphics to ctrl-alt-shift-up/down/left/right, and Atom could receive the ctrl-alt-up/down keystrokes now!

It seems even I disable the hotkey setting of the Graphics, the Win OS will still catch the keystroke as a global hotkey and will not pass them to Atom or other user applications.


#8

This is working, thanks !


#9

I ran into the same issue, I can confirm that it was the Intel HD Graphics control panel that was causing the issue for me.


#10

It’s working, thanks a lot!!