Why is there so mach space between letters?


#1

The spacebar’s also doing something like 2 of space.
how can i solve this?


#2

Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

#3

i’m on mac and the version of Atom is 1.8.0. How can i use --safe? i mean i don’t know where to do it


#4

Close out of Atom, open the terminal, and type atom --safe.


#5

doens’t work ,it says that ‘atom’: command not found


#6
  1. Launch Atom normally
  2. Select the menu item Atom > Install Shell Commands

Then you can exit Atom and launch it from the Terminal.


#7

i did it but the problem still persists. btw this problem appeared out of nowhere even in existing projects


#8

Do you have anything in your styles.less? You can open it by selecting the Atom > Stylesheet... menu item.


#9

yeah, i opened it


#10

But is there anything in there?

If you open Atom in developer mode (with atom --dev), you can right-click on one of the weird spaces and see how it’s being defined in HTML and CSS. If you can find out what the extra space is in the code, then that will probably shed light on what’s causing it.


#11

i think i found whats the problem.
.line has the ‘white-space’ set to ‘pre’, i set it to ‘normal’ and it worked,sort of, all the spaces were deleted but i when i try to make a space by myself it doesn’t work.
is there any method that i can use to reset Atom, like i have just installed it?


#12

Was that in styles.less?

is there any method that i can use to reset Atom, like i have just installed it?

You can close Atom, go into your ~/.atom directory, and move all of the .cson files to somewhere else. If Atom starts and sees no config files, it will generate the defaults.


#13

no it wasn’t in styes.less, i have just inspected the space


#14

It sounds like your syntax theme is the most likely culprit. Try changing that?


#15

it’s not the syntax, i tried changing that but the problem still exists. can you explain me the steps i have to do in order to restore the defaults of Atom with ~/.atom?


#16

i have even tried to reinstall Atom but nothing, i have the same problem. what should i do?


#17

If you want to restore Atom to 100% defaults, you can:

  1. Exit Atom
  2. Rename ~/.atom to ~/.atom-backup
  3. Start Atom again

#18

THANK YOU leedohm!!!

I was having the same issue as Emud. OSX 10.11.5 & Atom 1.8.0. I tried uninstalling using AppCleaner, I tried re-installing, I tried to find a config file that would affect the change and got nothing.

Followed leedohm instructions and it looks fine now. I just wish I knew what I did to cause the issue.

This issue was driving me crazy as it made code very unpleasant to look at in Atom. I was almost ready to give up.

Again, thank you leedohm!


#19

I believe the only things that can cause this, since it wasn’t mentioned, are:

  • installed packages (regular ones, and themes)
  • custom configurations
    • To see which configuration files exist, open the command palette and type “open your” and it will list the various configuration files you can open. If those are all empty, then no problem there.

What @leedohm suggested basically just erases installed packages and custom configurations. It also deletes Atom-specific settings (including settings of packages shipped with Atom), but I don’t think the culprit it there.

So, next time, to find the problem, you should try uninstalling packages one-by-one, and also deleting stuff from the configuration files one-by-one. When the problem is fixed after removing packages and configuration, then you’ll know what caused it.

If you learn how to use the DevTools (just read about Google Chrome DevTools which is what Atom uses), then you can debug there also. Look in View > Developer > Developer Tools to open the DevTools at the bottom of the Atom view, and you can inspect the HTML, CSS, and JavaScript environment from there.


#20

Thanks a lot man! finally works!