Why is the autocomplete view so unnecessarily wide?


#1

In the atom-typescript package for example (also happened with the autocomplete-python, haven’t checked others), the autocomplete list is really wide, that can be used to show information but as you can see from the example below most of it is blank and there is more information to show on the function as you can see on the right side. Why does it happened, is it a problem with the packatges (atom-typescript and autocomplete-python) or is it a problem with the autocomplete+ package or maybe in my own configuration?


#2

What UI theme are you using? Does it look wide like this with One Dark UI?


#3

(I took the liberty to clean up the title of this thread, to make it clearer. Hope you don’t mind)


#4

I use Nucleus dark ui


#5

Can you try using One Dark UI and see if you experience the same thing?


#6

Still the same


#7

Can you try running atom in safe mode (atom --safe)?
This should disable any community packages that may be messing with your views.


#8

I used atom --safe and the autocomplete view is still wide, I think it’s a problem with the autocomplete-plus package.


#9

Now that I tried it, I am getting the same with your example (css):

However, in a JS file it seems compact as expected:

So you might be right in that it’s probably something with the css addon to autocomplete (and perhaps others).


#10

My guess is that it has to do with the documentation at the bottom, I got the same result with autocomplete-atom-api in a coffee file.


#11

Yeah, @abe found the problem, it’s the JSDoc at the bottom or another documentation at the bottom, I noticed that selector autocomplete isn’t so wide but the properties is wide because the selector autocomplete doesn’t have documentation.


#12

Even with the documentation (which gets truncated with “More…” at the end), it’s still wider than the text requires.