Why is my Atom initial startup so slow?!


#1

I bought a new laptop just for Atom, but it still wasn’t as snappy as I thought at all with the below hardware. Is there anything I can do to improve this? Thanks.

Processor : Intel Core i7-7700HQ Processor (6M Cache, 2.8 GHz, 3.8 GHz max)
Display : 15.6" FHD (1920 x 1080), IPS, anti-glare, Non-Touch
Memory : 32GB(2x16) DDR4 2400MHz SODIMM
Graphics : NVIDIA GeForce GTX 1050 Ti 2GB DDR5
First Hard Drive : 1TB Hard Disk Drive, 5400rpm, 2.5", SATA3
Second Hard Drive : 512GB SSD SATA3 OPAL2.0

Here is what the initial startup looks like when I have all my packages on:



Here is what the 2nd startup looks like with all packages on:

Here is what the initial startup looks like in safe mode:

Here is what the 2nd startup looks like in safe mode:

The entire Atom (including .atom folder) sits in a SSD, only the code file is stored in a HDD.

Any advice would be greatly appreciated. Thanks.


#2

Window load time when not in safe mode would indicate something wrong with the app itself. (Are you on windows or Mac?)

And project load time being consistent across the board indicate a huge project?

Have you tried to compare the startup when not opening a project?

Maybe try to build the app on your machine from the source.


#3

FWIW, I’ve run Atom pretty successfully on an i5 laptop with 8 GB RAM and an HDD. It’s not blinding fast but not bad either. How many files in your project? Do you have any node_modules directories that aren’t excluded by your .gitignore?


#4

Thanks for the reply.

I’m using a Win10 laptop and everything is brand new. I’ve done a clean installation including the OS, so it’s not likely that the Atom app itself is corrupted or anything (I’m using the latest beta).

The project I opened is just a test project folder. All files are < 500 lines, and the folders don’t go very deep at all.

I’ll get you the load time when not opening the project after work. Thanks.


#5

Thanks for the reply.

This issue only happens in the initial startup when I start my laptop from cold. Once the cursor is allowed to move freely, there is no performance issue. Also from the above screenshots, you can see the second startup gets improved by a great amount.

The folder that got open is just a test project, not many files in it and they are all pretty small (< 500 lines), but covers a large range of files types, js, py, ts, etc.

The node_modules folder is excluded as it’s not shown up in tree-view

@skaraman @alflanagan Do you mind posting your startup time, so at least I can get a reference on what a normal startup should look like. Thanks.


#6

Here’s my start up on an average macbook -

Do you maybe have any kind of read/write restrictions in your C:\Users\you\Application Support\ (or maybe Application Data) folder

Have you tried the beta version?


#7

I’m actually using the beta version, and no, I don’t have any restriction cuz I’m using the admin account.

I checked my work laptop (which is a Mac Pro) today with the same packages, and the first startup time seems to be similar. I’m starting to suspect it’s probably the material theme I’m using that is causing the issue… (which actually doesn’t make sense) I’m running out of idea now…


#8

I have a very similar experience & have almost decided to go away from Atom back to Notepad++ because Atom is so slow at startup on Windows 10 (compared to NP++ & SynWrite). Very sad for me. I disabled all the nice Python related packages as this slowed load time considerably, and most of the time there are very few files in the folder. Timecop says Windows Load Time is 1…2s & Project Load Time 1…2s.


#9

Yeah, this can be very frustrating. Just wonder why having things running at startup and at the background not an option…