Why is atom continually "Not Responding"


#1

I’ve been trying to work on a project and open it for over an hour. If I load the project into Atom, it hangs with an error message like this:
atomerror

The project isn’t anything large, but I’ve just done a clean install. deleted .atom folder in the home directory, and deleted the atom folder in appdata\local and ran the uninstaller. (not in that order) and after a fresh install of 1.29.0 I still get this.

What gives?

Once again, this is after a clean install


#2

What does the full error say (with stack trace)?

Also, try disabling the github package and see if that helps.


#3

I wish I could even see the stack trace, but when the error occurs, the whole editor halts.

Is there somewhere it’s logged? I could grab it there.


#4

disabling the github extension did not work either. It’s something in the project that Atom proper doesn’t like. The odd thing is that it opens fine in VS Code, but my preferred is atom, but that is probably changing soon, if I continue with issues like this. (it’s been an ongoing thing that when I come back to Atom I have to reinstall just to have a decent experience.)


#5

It should appear in the dev tools (probably). You can them with ctrl-alt-i. Hopefully they are somewhat more responsive than Atom is being.

Also, you can check if a previous (or future) Atom version has the same problems

Edit: Also try opening Atom with atom --clear-window-state in the command prompt. This can solve issues related to botched specific project data Atom has stored.


#6

So it only occurs in one specific project?


#7

Hold on, I’ve only been trying to open a single project this morning.


#8

It appears to have been when I was starting atom with that project. I’ve opened another project, and it went through. Added the project I’m interested in, and it was fine.

Ugh… and no more error, so I can’t get a stack trace, and the Dev tools never launched when I tried before opening the suspect project. (it’s just a nodejs project with about 2k lines of code.)