Why I cannot install julia using Atom?


#1

I installed Atom in windows 10 and I have Julia 0.4 already installed. I would like to work with Atom as editor for Julia. I opened Atom and went to Install packages. I looked for Julia and then I tried to install Julia-client, ink, uber-juno but the process never terminates.

I mean when I click in the blue button Install it shows me that it is installing but it never finishes. Why?


Julia installation on Atom Windows 7 failed
#2

There is a known issue where the install finishes but the UI isn’t updated. If you restart Atom, the UI will update and everything will be fine. There is a fix that is in an unreleased version of Atom that is on its way.


#3

Thank you for the reply. However, no package is installed even when I restart Atom as you suggested.

I tried with the command line apm install julia-client and got the same problem. It said Installing julia-ide to C:\Users\Zou\.atom\packages but it never terminates (for more than 4 hours, so I stopped it). Maybe it is a Windows 10 problem?


#4

I haven’t heard of this with Windows 10 specifically. You may want to try using apm install --verbose to see if there is some more information you can get.


#5

I got the following :

C:\Users\Zou>apm install --verbose
gyp info it worked if it ends with ok
0.36.8
gyp verb cli [ 'C:\\Users\\Zou\\Downloads\\Atom\\resources\\app\\apm\\bin\\n
ode.exe',
gyp verb cli   'C:\\Users\\Zou\\Downloads\\Atom\\resources\\app\\apm\\node_m
odules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js',
gyp verb cli   'install',
gyp verb cli   '--target=0.36.8',
gyp verb cli   '--dist-url=https://atom.io/download/atom-shell',
gyp verb cli   '--arch=ia32',
gyp verb cli   '--ensure',
gyp verb cli   '--verbose' ]
gyp info using node-gyp@2.0.2
gyp info using node@0.10.40 | win32 | ia32
gyp verb command install []
gyp verb install input version string "0.36.8"
gyp verb install installing version: 0.36.8
gyp verb install --ensure was passed, so won't reinstall if already installed
gyp verb install version is already installed, need to check "installVersion"
gyp verb got "installVersion" 9
gyp verb needs "installVersion" 9
gyp verb install version is good
gyp info ok
Installing modules npm ERR! install Couldn't read dependencies
npm ERR! Windows_NT 6.2.9200
npm ERR! argv "C:\\Users\\Zou\\Downloads\\Atom\\resources\\app\\apm\\bin\\no
de.exe" "C:\\Users\\Zou\\Downloads\\Atom\\resources\\app\\apm\\node_modules\
\npm\\bin\\npm-cli.js" "--globalconfig" "C:\\Users\\Zou\\.atom\\.apm\\.apmrc
" "--userconfig" "C:\\Users\\Zou\\.atom\\.apmrc" "install" "--target=0.36.8"
 "--arch=ia32"
npm ERR! node v0.10.40
npm ERR! npm  v2.13.3
npm ERR! path C:\Users\Zou\package.json
npm ERR! code ENOPACKAGEJSON
npm ERR! errno 34

npm ERR! package.json ENOENT, open 'C:\Users\Zou\package.json'
npm ERR! package.json This is most likely not a problem with npm itself.
npm ERR! package.json npm can't find a package.json file in your current directo
ry.

failed 

#6

apm install --verbose doesn’t do anything by itself, you have to give it a package name to install.