Why HTML Snippets just stopped working?


#1

So I woke up this morning and HTML snippets were not working. Other language snippets seem to work fine. I did the normal searching to figure out the problem, but haven’t been able to find anything that helps. I completely uninstalled and reinstalled Atom, but that didn’t seem to help. I’m using Atom 1.22 on Windows 10.

When I tried turned on the keybinding resolver and typed “html [tab]” I got the following messages.

17

I’m fairly new to Atom. So maybe I’m just missing something. Any ideas?


#2

I haven’t tried out 1.22 yet, but my first instinct is that something may have changed in how Atom calculates snippet priority. You should be able to make a quick fix by adding this to your keymap.cson:

'body atom-text-editor:not([mini])':
  'tab': 'snippets:expand'

The problem with this is that it’s not trivial to bind multiple commands to a single keybinding from the same source. That’s why (as you can see in your screenshot) the snippets package uses two different keymap files.


#3

Seeing this too – is it a bug? Would be nice to know if it’s getting fixed.


#4

I ended up just uninstalling and moving back to 1.21. I only moved to 1.22 because I wanted to try out a package that is only available in 1.22. But I was wasting too much time on this and needed to get back to work.