Why first save file take so long?


#1

I save file first time after started atom , it takes a long time, some time it not response , this is why?


#2

just when i save file first time after atom start.


#3

me too on Ubuntu12.04


#4

If you can systematically reproduce that behavior you should try to profile what’s going on during the save process using the devtools to see where the bottleneck is.


#5

You can find instructions on how to profile things in the Flight Manual:

https://atom.io/docs/latest/hacking-atom-debugging#diagnose-performance-problems-with-the-dev-tools-cpu-profiler


#6

I’m getting this as well, running OS X 10.10.5, Atom 1.6.0.

Ran the profile:

During that giant block in the middle, Atom is unresponsive.


#7

That giant block in the middle appears to be some sort of “on save” functionality judging by the “Beautifiers” mentioned towards the right-center. Unfortunately, a lot of what you see in that screenshot is some package loading and activating. What package it is isn’t clear because most of the stuff that would identify it is probably past the cutoff:

What we really need is the saved profile, so that we can take a look at the data.


#8

Good thing I saved the profile! I hope you have better luck interpreting it than I do…

https://dl.dropboxusercontent.com/u/13874732/CPU-20160328T184112.cpuprofile

Thanks!!


#9

So digging into it, it appears that the vast majority of the time is spent in various Module._compile or Module._load functions. When I drill down into it, it seems that what it is compiling and loading appears to be the atom-beautify package. This would make sense that it only happens on first save (because on the second save the package is already loaded and etc).

Can you reproduce this behavior in Safe Mode? To launch Safe Mode:

  1. Completely exit all instances of Atom
  2. Launch Atom with the command atom --safe

#10

Thanks @leedohm! The behavior does not occur in safe mode, nor does it rear its ugly head when the beautify package is disabled. I suppose I’ll keep it that way for now, I don’t use the package too often.

Thanks again!


#11

Erm, I seem to be having the same issue, except I don’t have the beautify package installed.

Every first time I save a file after launching Atom, it takes a second to save. Every time afterwards it takes a few milliseconds. It’s not too bad, and I’ve lived with it so far, but it’s starting to get on my nerves.

I’ve tried disabling all packages installed by myself. I’ve tried safe mode. I’ve tried removing the .atom folder in my Users folder (using Windows 10 64 bit).

The strange thing is, on Ubuntu 16.04 (I’m dualbooting), this phenomenon does not occur.

But it does happen on both my Windows 10 machines.

I saved timeline files for the debugger for both a slow save and a fast save. I’m not quite sure what to make of them myself, though. The thing that seems to be (indirectly) causing it is an ipcRenderer.sendSync in an ApplicationDelegate.emitWillSavePath, and the sendSync is calling an anonymous function that makes it take so long (I think). No clue what that is, though.

Should I file an issue on GitHub? I can send over my timeline files, if needed.