Whitespace


#1

I’m working on a particular project where the source code has indentation on empty lines and is preserved with hard tabs. If I even so much as click on an empty space in this file, Atom removes the spacing.

I’ve tried several options in the whitespace package, and even completely disabled it.

This is a huge problem when I commit to the code repository as the diff becomes cluttered with all the ‘changes’.

Refer to image for clarity.


#2

It would be more helpful if you have some sample code and some steps that we can follow that reproduce the issue you’re describing. I can’t reproduce the behavior you’re describing using Atom v1.7.2 on Mac OS X 10.11.4.


#3

Sure.

  1. Turn on ‘show invisibles’.
  2. Open any suitable file with nested code.
  3. Press TAB a bunch of times.
  4. Click elsewhere and TAB indentation disappears.

I realize that for most people this is expected behaviour, but in these particular circumstances it’s not compatible with the editor my colleague uses, which is an old version of Eclipse.


#4

There are some settings for this in the built-in whitespace package. You can disable the removing of trailing whitespace there.


#5

I have tried these options in the package and tried even disabling the package all together but this doesn’t solve my problem. I’ll try and provide a picture example when I get back to my computer.


#6

In your reproduction steps you mention

Click elsewhere and TAB indentation disappears.

Which could suggest another one of your packages doing this because the whitespace package only removes trailing whitespace on save afaik. I also can’t reproduce the issue with the setting disabled using Atom v1.7.2 on Ubuntu 15.10. You can try to disable all non-bundled packages by starting atom with atom --safe and see if the problem persists.


#7

Okay wow, I’m stupid. I should have tested this in Atom with --safe first. It’s a package, I just need to find out which one.

Thanks guys.