Whitespace package removing newline spaces in Markdown


#1

I have the Atom (v1.5.3) whitespace package set to “Keep Markdown Line Break Whitespace” (the box is checked) and my config.cson contains these lines:

  whitespace:
    ignoreWhitespaceOnCurrentLine: false

(If I uncheck the “Keep Markdown…” box, then a corresponding keepMarkdownLineBreakWhitespace: false is added.) This is all to say that the config appears to be setup properly.

However, when I save a Markdown (.md, scope: text.plain.null-grammar) file, all of the double spaces at the end of the lines are being stripped out and my manual line breaks are lost. The rest of that package appears to be functioning normally and, if I set ignoreWhitespaceOnCurrentLine to true that works as expected.

Any ideas on how to track this down?


#2

Oooh, this one was easy to figure out: I must’ve disabled the language-gfm package at some point, so the correct grammar/scope wasn’t registering. Fixed!