White screen on startup


#1

Whenever I start atom, it appears to load but then only shows me a white screen. I’ve tried uninstall and reinstalling atom, deleting the atom app data. I’ve tried the beta version also but to no avail. I’m at a bit of a loss on what to do here. Do any of you have any helpful suggestions?


#2

There’s a section of The Flight Manual specifically about debugging, and uninstalling it is rarely the answer (it’s installed in AppData/Local/atom, so deleting that directory is the same as uninstalling Atom). What happens if you start Atom from the command line with atom --safe? What happens if you start Atom after renaming the .atom folder in your user directory?


#3

I’ve tried both of your suggestions. Starting Atom in safe mode leads to the same white screen. Renaming it does the same thing as well. I’ve noticed that the menu and underlying functionality seems to work, you just can’t actually see it happening. In the attached picture you can see me dragging a tab. My going theory right now is that this has something to do with how chromium is interacting with my computer, but I do not have a lot to back that up. Atom had been working great for months, until all the sudden it wasn’t.


#4

I’ve tried a number of the suggested fixes in that really nice debugging page, including starting in safe mode, clearing saved state, and resetting factory defaults. The rest didn’t really seem applicable. Version I’m using is below.

Atom : 1.16.0
Electron: 1.3.13
Chrome : 52.0.2743.82
Node : 6.5.0


#5

Interesting! How about atom --disable-gpu? Also, does Ctrl+Shift+I work (to bring up the Developer Tools)?


#6

ctrl shift I does bring up the developer tools, but I still can’t see it. It’s just completely white. I can tell because the pointer cursors are in the right spots.

Now the disable gpu command worked! Well it got atom working back to normal at least for that instance. I’m not sure this is a permanent solution though. I’d like to be able to figure out the underlying problem. If not, the only course of action might just be creating a script to open atom with the disable gpu command automatically. Any ideas on this?


#7

/cc @rsese: Any ideas on this?


#8

Ohhh I had done some digging into the white screen for an issue opened a few weeks ago and I went down a rabbit hole searching for possibilities. I found a handful of issues that were interesting but the only one that mentioned using atom --disable-gpu was an Electron issue 1. The report was about a black screen though 2 reports were also referenced where users saw a white screen with other Electron apps that were worked around with --disable-gpu.

I’m super curious, a couple of more questions if you don’t mind @addonisio.m?

  • It sounds like it’s the case that you’ve always hit a white screen but just to confirm, did Atom ever work for you? Just wondering if you randomly started seeing the white screen after it worked ok for a while.
  • What operating system are you using?

#9

I’m is using Windows 10. Atom had been working for a good 6 months and then all the sudden it did not. The only thing I could think that could even be tangentially related that happened around that time was I was trying (and failing) to connect my laptop to a projector. The connection broke while trying to install the driver. Honestly I have no idea though.


#10

Just change GPU from Nvidia to Intel in the settings.
This action helped me.


#11

Right click on the Desctop - NVIDIA Control Panel - Manage 3D Settings - Program settings


#12

Hello, I had the same issue until I tried to switch the compatibility mode from Win10 to Win 7, that helped me ou4t. :smiley: Hope it gonna work for you too! have a nice day Y’all! :wink: