Which package creates a "null" folder in the project?


#1

I am not sure how to pinpoint this, I can only assume it’s a Linter that does this.

Something that acts upon saving a file, creates a folder called "null" with what looks like a list of transpiled / auto-generated Javascript files:

gif

I’m not sure where they come from (most likely sourced from the underlying meteor scripts in .meteor), but it doesn’t really matter because all I need to know is which package just runs through the project and creates a bloody null folder every time you save something.

Anybody know the answer off the top of your head, before I go via disabling each of them one-by-one?


#2

I just noticed three things:

  • It seems not to be the Linter (tried disabling it, reload, still happening)
  • If I change file outside of Atom, it still happens.
  • If I change the file inside of Atom (but without saving it), it also happens, so its’ something that watches even just while typing (which sounds Linter-like, doesn’t it?)

#3

Looks like some watcher automatically compiles/transpiles your javascript files. I have no idea which package causes this, but you could try @mark_hahn’s PackageCop. Might help you find the culprit faster than disabling all packages one by one.


#4

Yea, I’ll finally have a reason to find out how the PackageCop actually works :wink:


#5

It works pretty good, but the UI is horrible.


#6

So I watched this issue a few more times, the null folder appearing out of nowhere for anything I did… then I installed the package cop and tried to reproduce it… nada.

I kept activating and deactivating all the packages in the list, one-by-one, reloading atom many times inbetween and it just wouldn’t happen anymore.
It looks like the mere presence of the cop petrified the evil doer into silence. :scream:

I’ll keep an eye on it for a while longer, maybe I do catch it again.


#7

Hi @batjko, it looks like you’re facing this issue. I still have no clue as to why it occurs. It appears it’s a windows only issue, but that’s the only lead I have on this case.


#8

Ah, interesting. I do have pigments installed as well, but since, as you say on the issue, pigments doesn’t really create any temporary files, I’m sure there is another package involved, that just happens to look at the wrong folder (in your case the pigments’ package folder?).

The next time this happens on my machine, I’ll have a closer look at the files created. Since the package cop was cop-blocked here, I might have to investigate the hard way anyway.


#9

That’s a quantum bug, a Heisenbug! You can’t debug it without making it disappear! :slight_smile:


#10

:laughing: Ha, love that!


#11

I didn’t make it, but I sure try to use this puntastic pun whenever I can :wink:


#12

Alright so it does indeed seem to be the pigments package, @abe. Or perhaps with one of your dependencies?

Package cop caught the issue this time, and only after I disabled Pigments did the behavior stop. And in my case also, it was all Pigments-related files in that null folder.

So not a Heisenbug anymore, but still a total freakbug.


#13

Ha! Love that one also. You are Two Wild & Crazy Guys.