When developing a plugin, changes not loaded on Atom refresh


#1

I’m currently developing a new Atom plugin and running into this issue. Any changes I make to the package aren’t reflected in the Atom interface when I run Window: Reload. I’ve already run apm link from my package’s root directory, and I’ve verified the symlink to my package has been set up correctly in ~/.atom/packages.

As an example, I renamed the default command, toggle, to showIdentifiers and made sure it was registered in the main setup file via atom.commands.add. However when I run Window: Reload, the Packages -> context menu still shows the old toggle command. Running the toggle command produces no console output, no errors, no anything.

Any help you could provide would be most appreciated!


#2

It would be easiest if you shared the GitHub repo. Then someone could download your package and see what commands appear for them.


#3

Sure thing. The Github repo is this guy: https://github.com/camertron/innuendo-atom


#4

The menu command is specified here. So, even though there’s no toggle left, the part of Atom that assembles the menu still thinks that it’s there.


#5

@DamnedScholar Ah that was totally the problem. Thanks for answering this n00b’s dumb question!


#6

No problem. :slight_smile: