What's this .bin package?


#1

It appeared somewhere in the last few Atom upgrades, after the new packages display layout.

I am on Atom .174, OS 10.10.1


Anyone else have Autoprefixer issues?
Anyone else have Autoprefixer issues?
#2

I don’t see that. Could it be that you have a .bin file or directory in your ~/.atom/packages or ~/.atom/dev/packages directories?


#3

I do. No idea why. It seems a symlink to autoprefixer is in it. This might also explain why autoprefixer doesn’t work for me any more.


#4

OK, I removed it and autoprefixer. Re-installed autoprefixer, and .bin has returned.


#5

According to npm’s documentation on package.json

A lot of packages have one or more executable files that they’d like to install into the PATH. npm makes this pretty easy (in fact, it uses this feature to install the “npm” executable.)

To use this, supply a bin field in your package.json which is a map of command name to local file name. On install, npm will symlink that file into prefix/bin for global installs, or ./node_modules/.bin/ for local installs.

I don’t know what caused this though… I would assume this feature is turned off in apm

This didn’t happen for me when I installed autoprefixer from inside atom


#6

I tried today installing from inside Atom and via APM and got the .bin folder both times.


#7

@smlombardi have you opened a bug on the settings-view package yet? If you haven’t, could you open one and post a link to it here? Maybe the Atom team will decide it belongs on apm or maybe they’ll solve it on Settings View … either way, it should be looked at.


#8

Issue opened https://github.com/atom/settings-view/issues/348