What is this separator line in the document view?


#1

Sorry for the short question, but I did search… :smile:

Please see screenshot:

http://imgur.com/IRNeI3f

What is this line?


FAQ: Best Practices
Archived FAQs (see FAQ category for all current FAQs)
#2

That is the soft wrap line. See your settings:


#3

Interesting. I see it even though both are disabled/enabled…


#4

It’s the “Preferred line length” you will want to change then. If you’re not using it to wrap text, simply change the value to something large, say 200 or so.


#5

Just disable the Wrap Guide package and it’ll go away. No need to change the preferred line length setting.


#6

I didn’t know that was a package of its own. Whaddayaknow.


#7

You can also set the wrap guide on a language-by-language basis. Here’s an excerpt from my config.cson:

'wrap-guide':
  'columns': [
    {
      'scope': 'source.gfm'
      'column': -1
    }
    {
      'scope': 'text.git-commit'
      'column': 72
    }
    {
      'scope': 'text.haml'
      'column': -1
    }
  ]

Anything that isn’t mentioned above has the wrap-guide at the preferred line length. Anything that is mentioned above and uses a non-negative integer as the column value displays the wrap guide after that column. Using a negative integer as the column value turns off the wrap-guide.


#8

Pretty cool. I want word wrap to 75 chars, but the indent guide should be at 80. So I used this:

'wrap-guide':
  columns: [
      { pattern: '.', column: 80 }
  ]

And I set the preferred line length to 75. An empty pattern didn’t work, and a pattern of '.*'wasn’t necessary.