Weird spaces not found


#1

Hi there,
Apologies if this has been asked before but I cannot seem to find a resolution, i dont even know how to search for it properly.

I’ve opened up an .rdp file and the contents therein look like this:

I want to do a find-replace to get something like “u s e m u l t i m o n” to look like “use multimon” but the spaces in-between the letters dont work in find. In other words, if i copy:

and then try to paste that into the find box nothing pastes, even with regex mode.
If i copy without the leading space:

then only the first letter pastes into the find box:
(i removed all my images because new users can only paste one image, so i hope this image suffices. Please ask for more if needed)

What is happening here? How can i achieve what i’m trying to do?


#2

Do the weird spaces appear when you open the file in a different editor? What happens when you open the settings and turn on Show Invisibles under Editor?


#3

Hi there,

If i open it up in notepad it displays exactly the same except notepad has no line-breaks.

I did try the show invisibles command from the ctrl-shift-p launcher but it didnt seem to make any difference.


#4

Okay, that might be relevant. What line endings do you see in Atom? (To look at the line endings for the file, check the status bar for CR, LF, CRLF, or Mixed.)

Where did you get the rdp file? Does this phenomenon happen with any other files?


#5

Windows rdp-files are using UTF-16 LE encoding. After switching the encoding, you should be able to edit the file as usual.