Weird red color highlight in quotes in php using ( language-php package )


#1

PS. I have tried to fix it by changing theme but it didn’t work. I tried disable php language-php package but it removes all hightlight including mentioned problem. Can anyone help me fix this issue


#2

Hi.

The colouring you see there is a marking for “error / invalid” statement. It is given by the language or by the linter-package looking after the format of the coding.

That is as far as I can tell you. Review the format of the code… as well as the code before. This can including missing [ ] ( ) { } ; " ' : in previous coding.

Good luck.


#3

Thanks for replying. There is nothing missing in [ ] ( ) { } ; " ’ : as code is running perfectly fine. color hightlight is behaving weirdly. interestingly if copy and paste this string in other page it show same strange highlighting. the issue not only for me it is noticed by my developer colleagues in office as well.


#4

Hi. Best then to have someone familiar with the grammar to give an answer. All I can tell you is that, that colour is normally used to mark invalid code.

The one way to confirm is to use the development tools for Atom (CTRL-SHIFT-i) to confirm as what the that piece is identified as.

Is there a way for you to split the code over several lines? Perhaps it is a readability “warning”.

dP


#5

it could be readbility warning. How could I disable them. The hightlighting got fixed in one of the two lines intended string into one line. But I need string on multiple line for readability. I would like to disable it. I read this package (language-php) is made form textmate code. may be it is a bug in package. but How can disable highlighing while keeping package enabled? Thanks again.


#6

Please file an issue on the language-php repository and I will look into it.


#7

@ejaz: Here is where you can go: Atom => Language: PHP => Issues
HINT: Please supply as much information as you can. A text example would help.