Weird Line in Atom


#1

Hi, what is this line & how do I disable?
And also, can I disable auto-correction of grammars at all?


#2

That is the Preferred Line Length indicator. You can turn it off by changing the .Preferred Line Length setting in settings. Set it to something big to hide it.


#3

Worked. Thank you!
What about my second question, is it possible to turn off grammar check at all?


#4

I’m not sure what you mean by grammar check. You can click on the right side of the task bar to change grammars. If you mean to turn off all grammars in Atom then I don’t know. Maybe someone else knows grammars better than I.


#5

Yeah, I mean to turn off it completely. For example in my screenshot, there are some words with red lines highlighted, which grammar can’t detect, so in this file I don’t want grammar at all. I checked in settings & couldn’t find the option to turn it off completely.


#6

You can go to the bottom right grammar button (name of current grammar) and change it to plain text which will be remembered.

If you are going to use Atom for programming then I think you will regret this. (grin). I’m sure it is possible, maybe in init.coffee, but I don’t know how off-hand.


#7

I set it on plain text, but it still highlights those words.
I’m not going to use it for programming, just opening mostly readme files (I like game modding & tweaking). Would be good if I could turn off/on grammar in individual files by pressing a shorcut on keyboard. Hope developers will make it available in next version. Anyway thx for replies & help!


#8

Then the red-lines have nothing to do with grammar. Maybe spelling?

Try running atom from the command line with atom --safe and see if the red lines go away. Safe mode will disable all community packages.


#9

By the way, there’s a FAQ for this: