Weird flex-grow style on an active pane on Windows


#1

If I run Atom on a specific directory via command line atom . since some time it started to open like this:

It’s only this directory and it’s important for me because I often run Atom from .cmd scripts. With other directories it’s running ok.

This gap also disappears when:

  • open another Atom window and open this folder
  • open a project which mapped to this folder in Project Manager

I’ve tried with no luck:

  • running Atom with the --safe option
  • reinstalling Atom
  • disabling all community packages
  • removing all editor-... files in ~/.atom/storage
  • removing all folders in ~/.atom/compile-cache ¯\_(ツ)_/¯

Thanks for the help!


#2

This is the ability to resize panes, which it appears allows you to resize even a single pane when there are no others :grinning: You can use the “Pane: Increase Size” command in the Command Palette to increase the size again.

The ~/.atom/storage directory no longer stores serialized editor state. If you want to clear this state, you need to close Atom and launch it again from the terminal with atom --clear-window-state.


#3

Thanks, @leedohm! --clear-window-state fixed it, it is what I was looking for. “Pane: Increase Size” also worked, but it missed flex-grow: 1 for some reason making it a bit greater flex-grow: 1.09146, but visually it was fixed anyway :smiley:.


#4

Ugh. This was really annoying, took ages to figure out. Thanks for the solution!


#5

There is a FAQ for this now:


#6

:raised_hands:
thanks a lot it’s perfect for me :ok_hand:t2: