Weird discolored background rectangles


#1

Hello,
I am using the An Old Hope syntax theme + One Dark UI, and I’m seeing weirdly discolored rectangles in the background of the editor.

This only started happening when I updated my Nvidia driver from version 390 to 410.

I know there’s a related topic:

I was wondering if I could add the additional --enable-gpu-rasterization argument automatically when I start up Atom, as I don’t want to open the terminal each time I want to run the editor.

  • OS: Ubuntu 18.04
  • Atom: 1.31.2 from deb package

#2

Hello.

Please review this setting:

Make it the opposite of what it is set for you at the moment.

The alternative is to calibrate your monitor. I used Spyder5 Express on my Windows PC because of my photo editing hobby.

Cheers.


#3

I tried switching to the sRGB color profile, but the colors are all washed out and out of place now.


Use color profile configured in the operating system, nice and vivid colors, but squares in background

Use sRGB color, colors are all washed out and out of place. Not visible on the screenshot, but clearly visible on my screen

I don’t know how to calibrate a display, could you please give me some advice on how to do it, if it’s absolutely necessary?


#4

Have you tried using a colour picker to sample if the colours are really different?

One work-around is to change the lighter background colour to match the far back colour that you are seeing in the first picture. {preferred suggestion}

Another work-around (guessing) would be to go into the settings of your graphics card and have the built-in graphics be used when using Atom. Now this assume you are on a laptop PC that has something like Intel graphics built-in with the Nvidia card.

The next is to calibrate the screen. The procedure would be different for the OS you have. You will have to do your own web-search for this; I’m exclusively on Windows.

What are your thoughts?


#5

I didn’t try a color picker yet, but on the monitor they’re definitely different. I might try to launch two instances of Atom, one with calibrated color and the other with sRGB color and taking a photo. Just tried that, it’s not possible. But I assure you, on my monitor they look different (especially the intense blue and red, they look desaturated), and after doing some monitor calibration tests, it turns out it’s already properly calibrated.
I’m not using a laptop and don’t have an integrated graphics card in my CPU.
The method with switching to sRGB seems to remove the background squares however, so it might be onto something.

Edit: I also noticed, the bright background squares with text seem to have the correct color, and the rest is forced to sRGB.