Weird bug with spacing with certain fonts


#1

I prefer to use Droid Sans as my font, but when ever I set my font to that I get weird behavior with spacing.

Here is what is happening when set to Droid Sans. Note after I type the colon and space.

Here is what happens when I have the font set to menlo and it doesn’t act weird.


Am I the only one with cursor position issues?
#2

Seeing the same thing with Source Code Pro and, please forgive, Comic Sans MS. It did get a bit better after updating from 0.62.0 to 0.65.0, but it’s still there.


#3

Weird, I am not seeing this and I use Source Code Pro for everything. Here’s what I’m working on:

  • OS: OS X 10.9.2
  • Hardware: Mid-2011 iMac
  • Font: Source Code Pro v1.010
  • Atom v0.65.0

Have you tried downloading the latest version of the Source Code Pro fonts?


#4

I did and had the same issue. Then I just switched to a different theme and back and now it works. Even after a restart of the editor. Weird, but works for me.


#5

I’m updated to 0.65.0 and still have the same issue. Seems to be an issue with certain fonts. Both droid sans and serif have this issue. Another installed font, inconsolata, works fine however. And another installed font, squarefont, also has this problem.

I’m also on OS X 10.9.1 on a mid-2013 Macbook Air.


#6

I think that this is easily a bug - I’m using Source Code Pro on a retina and seeing similar issues. There are clearly some problems with the font layout in the editor right now ( just try adjusting your line-height and you’ll totally mess everything up ). For some - everything works just fine, for some it doesn’t.


#7

I have the same setup and after switching themes back & forth it works for me now (constantly even).

Setup: OSX 10.9.2
15" rMBP 2013
UI Theme: Atom Soda Dark
Syntax Theme: Tomorrow Night
Font: Source Code Pro (the latest version)
Font Size: 15