VHDL-Linter


#1

Hi,

the VHDL-Linter has now the ability to include custom arguments in the top[ of a VHDL file, like: – args: --ieee=synopsys…

I’m using in VHDL the “std_logic_unsigned” library and without the “-- args: --ieee=synopsys” argument, the linter complains that it cannot fine the library in “ieee”.
That works fine, but the linter complains also about the fact it cannot find other libraries, these are:

  • Xilinx Unisim vcomponents library
    The xilinx libraries are compiled with GHDL and placed in a directory “xilinx” with the other GHDL libraries.
  • All instantiated component using the entity instantiation method.
    <component_name> : entity .
    is a directory where the source code of the <component can be found.

What is the syntax for the arguments?

  • For the Xilinx libaries I tried the follwoing (without success).
    – args: --unisim=/opt/Ghdl/lib/ghdl/xilinx/unisim/v93 (this is the path to the GHDL compiled library).
  • For the instantiated components I tried similar, also without success.
    – args: --prbs_lib=/project/libraries/prbs_lib (this is the folder where for the prbs.vhd source code file).

Many thanks in advance for any help/hints.

kind regards,

Marc