Vertical Line In Editor


I think this could be solve by using a dotted line instead of the current solid line. Since atom’s UI design is flat and the line doesn’t react to mouse hover or other mouse behaviours (there’s not affordance for it), the first thing that cross your mind is that the line could be a potencial UI bug. A dotted line would be distinct enough to make you think that the line is part of the UI and it’s probably a sort of guide.

A shortcut would be helpfull too :wink:


Hi danielyewright~!!
How can I get a vertical line in your screenshot??
I want to know How to setting like you~


Thanks. For some reason .editor { .wrap-guide { } } isn’t working for me.

I used:

atom-text-editor::shadow .wrap-guide {
  opacity: .3; //barely visible


Also I feel it’s an appropriate time to note that the default styles.less file comes with two lines that are longer than 80 chars.


My solution for this issue:
I’m using dracula-theme – beast ever for programmers

Clear and not that visible as white.

Add in file styles.less:

 atom-text-editor::shadow .wrap-guide {
  opacity: .06; //barely visible
   background-color: cyan;


this is what did it for me. Thanks.


I desagree too.


Thanks ohm That worked for me.


Yeah thanks for this. I had that line show up randomly and it made some of the code difficult to read.


Oh God… uninstalling the package worked perfectly for me. It started showing up last week automagically and became super annoying super fast. Thanks for the quick fix!!


Settings - Packages - Core Packages - wrap-guide. Disable/uninstall it. It doesn’t show on mine anymore.


There is a FAQ for this now:




Here’s what I’ve got running for a dashed alternative and it’s working great:

atom-text-editor::shadow .wrap-guide {
    background: transparent;
    border:1px dashed rgba(255, 255, 255, .05);
    border-width: 0 1px 0 0;


It worked nicely for me! This line started to show up once after the latest update.


My issue (just installed atom) is that it is not honoring the editor.preferredLineLenth setting. It’s showing it a column 80 instead of 132 and specified in the editor preferences.


I am unable to replicate this. Please share the version of Atom you are using, your config.cson, and a screenshot of how your editor is behaving.


Over 2 years since you posted this–I made an account just so I could ‘Like’ your answer. Thank you!


After trying to figure out what was wrong with panes for a while I found this… nothing like starting to use an editor and you can’t even view a file full screen…

I nearly tossed the editor just because of this alone. Thank goodness I found this comment.


For me, this solved my problem.

atom-text-editor {
  &::shadow .wrap-guide {
    visibility: hidden !important;