Vertical Line In Editor


I recently started seeing a horizontal line that I cannot seem to get rid of.

Here is a screenshot:

I do not remember seeing it before last night, but now I am not sure where it is coming from.

Any suggestions?


Solid line down right side of editor
The black line down the middle of Atom
Atom Environment
Open console on Windows

If you don’t want the line anymore, just disable the Wrap Guide package. This is the culprit.


That did the trick. Thanks for the tip.


The line serves as a useful guide to keep the width of your lines less than a certain number of characters (most style guides say 80).

Also the line is vertical, not horizontal. It might be helpful to others who are having the same issue and searching if you could edit the title.


I have this problem as well. Even after uninstalling wrap-guide via…
apm uninstall wrap-guide

A vertical line still renders in the middle of my editor.
Any ideas how to force this line to go away?


He suggested disabling, not uninstalling. You might have to restart Atom after uninstalling the package. You could also use this in your stylesheet:

.editor {
  .wrap-guide {
    visibility: hidden;


Thanks! This helped a lot!

.editor {
    .wrap-guide {
        visibility: hidden;


Great idea:

I used something like this:

.editor {
    .wrap-guide {
        opacity: .05;


This should not be enabled by default, I feel like more people will want this disabled at startup than otherwise.


You can also just place the .wrap-guide css in the atom-text-editor rule:


I disagree. Long lines are bad.


This didn’t work for me (version 1.0.0)


For version 1.0.0

atom-text-editor::shadow .wrap-guide {
    visibility: hidden;


For version 1.0.0
-search for “wrap-guide”


Lets say that i want to keep the good style (80 line) but i just move from sublime3 > atom 1.0 and i have a huge code base, is there some package to wrapp my code to follow the 80 lines style? or i just need to adapt it manually? i.e bottom


There is the autoflow package. But it isn’t code aware, so it will just break on whitespace … which might not be syntactically valid depending on the language.


Although it’s not very obvious, the wrap guide is a package that can be disabled. Which makes a lot more sense than hiding it with CSS.


My suggestion is reducing opacity to subtle color. that way it is not annoying like white line but still preserving code folding .


The autoflow that I mention above is not dependent on the wrap-guide being enabled. They both use the editor.preferredLineLength setting that is separate from both packages. You can disable the wrap-guide package and still have autoflow work.


Yes, softwrap or any other wrap feature doesn’t depend on the wrap guide package. It just does what is says on the box: show a wrap guide.