Vertical Column Selection


#1

This is a must feature which the mac is lacking today.

I’m using Mac and not able to use this feature to edit multiple lines at the same time.


#2

Atom has multiple cursors. It’s similar. Go somewhere, then use Ctrl-Shift-Down to move the cursor down and to mark multiple lines. Then you can expand the selection to the right with Shift-Right.

But it’s also more flexible: For example, you can do Shift-Option-Right to mark a word in all lines, and that will usually not result in a rectangular selection. Instead, the number of characters marked in each line will be different and it depends on the length of the word there. Or you mark to end of line. (Shift-Ctrl-Right when not on a Mac.)

Another thing to try is Cmd-D (or Ctrl-D when not on a Mac). This marks the current word. If you repeat it, it will search down for more occurrences of the same word. You can then cut them, copy them, replace them with something else, prepend things, append things, and so on.

You can also use Shift-Right to select some text (not necessarily a word) and then start using Cmd-D (Ctrl-D) from there with much the same effect as before.


#3

Ctrl-Shift-Down takes the atom window back a little bit.

Ctrl-Shift-Up works though.

What is the fix for this?


#4

What does this mean? I don’t understand what happens when you hit Ctrl-Shift-Down. Are you on Linux? Perhaps it’s a keybinding swallowed by your window manager?


#5

I am on Mac. It is likely that the mac is consuming that key binding. Thanks for the help.


#6

I see. Well, it should be easy to tell the Mac not to use this keybinding :sunny:


#7

For any future readers on OSX, here are the instructions I followed to disable the mission control ctrl+shift+up/down key bindings: http://apple.stackexchange.com/a/116716


#8

Good tips.

One annoyance is that Ctrl-Shift-Down (and Up) only extends the selection, we cannot reduce it.
Another annoyance is that the selection extension is applied to visual lines, not to physical ones. Ie. if Atom wraps lines (which it does by default, no?), if you extend the selection vertically, it will select over the wrapping, instead of skipping these parts. It is not logical nor useful. I think I will file a bug, if there is not one already.

For the record, I use the Sublime Style Column Selection package to also allow column selection with the mouse.
Oh, and out of the box (ie. no need for the above package), Ctrl+click also allows multiple carets.