Version 1.4.7 and Markdown Preview

Hi All,
I have just upgraded from 1.4.6 to 1.4.7 on Mac and Linux (Ubuntu and Mint). I use Markdown Preview Enhanced to preview as I write. Since upgrading to 1.4.7, while it activates the preview pane, but nothing come up. If I deactivate MPE, and active the built-in Markdown-Preview, I get a error quoting “Previewing Markdown Failed r.trim is not a function”.

I get this on Mac and Linux. I get it if I delete .atom folder and config files and re-install from scratch. I get it with MPE version 0.17 and if I upgrade to MPE 0.18.

The problems go away if I revert to 1.4.6 (on Mac and two versions of Linux). I get no error message with MPE, just a blank pane, and I only get the error quoted above using built-in markdown-preview.

Anybody have any ideas?



I just confirmed that the same problem (preview pane appears, but is blank) if I process a LaTeX file using atom-latex 0.9.1.


i met the same error
and … i have no idea…

I was on Atom 1.44 using markdown-preview-enhanced and reading this I updated to 1.47 and exactly the same results … blank preview. This will need to be reported as an issue at markdown-preview-enhanced site. I notice that mermaid-preview still works (this uses markdown)

Actually this issue has been raised already.

Note: As an interim step until Atom 1.47.1 arrives i am using pandoc commands to preview markdown files. This also applies to LaTeX.

Ok, I have just updated to 1.4.8 and previewing LaTeX and Markdown is now working.

Thanks to those who fixed this.

I am still seeing this on Atom 1.49.0 on Mac OS.

1 Like

Me too on macos catalina 10.15.6 on atom 1.49.0.

I’m also getting this error now when trying to preview .md file. Yesterday I updated to macOS Catalina 10.15.6. Two days ago, I was editing this same .md file on macOS Catalina 10.15.4 and could preview markup with no problems.

1 Like

Edit: Error appears the first time I try to preview markdown. If I close the preview window and try a second time (Packages > Markdown Preview > Toggle Preview), the preview then appears properly.


There are two separate packages: markdown-preview and markdown-preview-enhanced (there might be others if you search markdown). I use markdown-preview-enhanced.

Thanks Cathy. This works, everyone! (On a mac, on a Monday morning, minutes before a presentation to the boss to explain why I’m changing the content she asked for.)

… then your boss will be blown away by the presentations output from markdown-preview-enhanced. Right click on markdown-preview-enhanced (as distinct from markdown-preview) preview window and you see options to create reveal.js presentations … and also custom pandoc output driven by yaml frontmatter in raw markdown. Same author of reveal.js developed the website

Thanks @cathynewman, your suggestion fixed the problem for me.

1 Like

I upgraded from 1.50.0 to 1.51.0 and the issue appears to be fixed. In previous versions I was also able to update the contents of the Markdown file to force a successful redraw.

I had the same issue in v1.52.0 x64 on MacOS 10.15.7, I simply went to Toolbar/Packages/markdown
and selected Toggle GitHub style. And it started working.

1 Like

Your fix works on Windows 10 too. Same atom version. markdown-preview 0.160.2. I’ll check to see if I should file an issue with the package.

Edit: there is a related issue here:

Edit (21 Nov 2020): It’s not working well. I have to keep toggling it on and off to fix the error now.

I’ve found a solution and a package with more features to use, but it involves no longer using this Core Package.

In case the link fails: try markdown-preview-plus!

and see my comment in issue #579 of markdown-preview.

Closing the preview window and then toggling it again worked for me too. Thanks!

1 Like

Thanks @cathynewman you absolute legend, can’t believe I didn’t try turning it off and on again myself.

It’s gotta be an order of operations / dependency load issue, because the first time it fails but somehow allows it to load the second time.
This is probably a very naive analysis but idunno, I hope to inspire someone whom’st can fix it.

Atom 1.53.0 x64