Various elements on the page are not wrapping anymore since 1.9 or 1.10 windows


#1

Using 1.8, everything was fine, was force to upgrade to 1.10 recently(even though I had auto update off, but that’s another topic). The output of various elements don’t wrap properly anymore.

  • The output of script doesn’t automatically wrap anymore. For example, in python, this code will only produce 1 line with a horizontal scrollbar:
print(list(range(300)))
  • Code blocks in the markdown preview don’t wrap either. Having a very long line of code between triple backticks will also produce a short block with a long horizontal bar. example of long line
SELECT id,carid,type,field,replace(data,'"','\'') INTO OUTFILE '/tmp/carout.csv' FIELDS TERMINATED BY ',' OPTIONALLY ENCLOSED BY '"' LINES TERMINATED BY '\r' FROM field WHERE carid>=3911;

It seems the preview on this site also has this behavior

Please provide an option to have wrapped output, or at least to revert back to 1.8.


#2

The reason why this would be happening is different CSS rules regarding <pre> tags. I was able to force the code in the script output panel to wrap by adding this to my styles.less:

pre {
  white-space: pre-wrap;
}

When you preview Markdown, a different thing happens. Try wrapping a whole paragraph with backticks, then inspect it and you’ll see that it doesn’t use just one tag for that block of text. The package appears to decide how wide the block should be and then break it up into separate divs.

You can access old versions of Atom here.


#3

One of the features of code blocks is that they are represented exactly as they are typed. Soft wrap shouldn’t reformat them. You could make the case that they shouldn’t scroll individually separate from the view and that could be valid but reformatting them wouldn’t be a proper preview.