v1.54 windows-10 settings pane stuck 'Loading packages'


#1

I am following the manual install instructions on: https://github.com/JunoLab/atom-julia-client/tree/master/manual

I have Atom installed and julia is on my system path. When I open the settings tab, I find all of the bluish boxes stuck forever “Loading packages”

Not only do I need to figure out how to break out of that loop, but I also don’t understand what “install the packages language-julia, ink and julia-client” actually entails. Install, HOW, specifically?


#2

To install an Atom package you can:

  1. Launch Atom
  2. Open the Settings View using Cmd+, on OS X or Ctrl+, on other platforms
  3. Click the Install tab
  4. Type the name of the package you want to install (make sure the Packages button is clicked on the end of the input box)
  5. When you see it in the list, click the Install button

Or you can:

  1. Exit Atom
  2. Type apm install package-name at the command prompt
  3. Launch Atom again

#3

apm on windows-10 ?

The Install tab did give me “‘D:\Programs’ is not recognized as an internal or external command,
operable program or batch file.”

when I tried to install language-julia, so some configuration setting is obviously ‘off’. Any suggestions there?


#4

Yes, apm was installed with Atom. Whether it is on your PATH is a different story. Did you use the installer from https://atom.io?


#5

I did use the installer, but it doesn’t give you an option on where it gets installed. I moved the install directory to my D drive and might have broken something in the process. apm was not on the path, but it is now and I get …

apm install language-julia /d/Programs(x86)/Atom/bin/../app-1.5.4/resources/cli/apm.sh: line 2: ‘\r’: command not found
/d/Programs(x86)/Atom/bin/…/app-1.5.4/resources/cli/apm.sh: line 4: /d/Programs/…/app/apm/bin/node.exe: No such file or directory

I really hate everything going to C (it gets overloaded fast): Wish the package directory could be on D too.

Restarted Atom and still get the same error trying to install packages from Settings>Install

so… still sort of stuck.


#6

If you install Atom using the installer, Atom is going to expect things to be in the typical locations. You can point Atom to a configuration directory wherever you like using the ATOM_HOME environment variable.


#7

Hmm, from where exactly did you install Atom?

The official Atom installer for Windows is at: https://atom.io/download/windows . That installer doesn’t install to “Program(x86)”. Instead, it installs it at “%LOCALAPPDATA%\Atom”.


#8

Yes, that’s where I found the installer (figured that it would be windows-wise). LocalAppData is supposed to be for data (e.g. templates, resource files, and other non-executable stuff), definitely not executables, link libraries, shell scripts, etc. I moved that directory to D:\Programs(x86)\

Anyway, I now have ATOM_HOME defined, but everything still behaves the same - I still get:

‘D:\Programs’ is not recognized as an internal or external command,
operable program or batch file.

when I try to install language-julia from Settings>Install

apm install language-julia in a fresh shell still bombs out the same way as before.


#9

Yes, ATOM_HOME only points Atom to where your configuration files are … not the program files. If you want Atom to work properly at this point the easiest thing would be to put Atom’s program files back where you found them or reinstall Atom.


#10

If the installer allowed installs elsewhere, I’d be happy to reinstall, but my C drive is too full to let the installer dictate the install directory.


#11

It may be possible to relocate the Atom installation elsewhere, but there’s definitely more to it than just moving a folder. You could try this, but there’s no guarantee it’ll work.

  1. Unset the ATOM_HOME environment variable. (This variable has nothing to do with the Atom installation folder, and if you set it to the Atom installation folder, that would explain the odd errors you are seeing.)
  2. Install Atom as normal.
  3. Move %LOCALAPPDATA%\Atom to its new location.
  4. Update your system-wide PATH environment variable, removing %LOCALAPPDATA%\Atom\bin and replacing it with the new location of the Atom\bin folder.
  5. Restart all Command Prompt windows, if you have any open.
  6. Try starting Atom by typing atom into a Command Prompt window. If it works, try going to Settings > Packages and see if things work as expected.

I believe that might work.


#12

what you’re describing is essentially what I have already done. atom starts from a shortcut, but when I open a fresh shell, I get…

atom /d/Programs(x86)/Atom/bin/../app-1.5.4/resources/cli/atom.sh: line 2: ‘\r’: command not found
/d/Programs(x86)/Atom/bin/…/app-1.5.4/resources/cli/atom.sh: line 4: syntax error near unexpected token $'in\r'' /d/Programs(x86)/Atom/bin/../app-1.5.4/resources/cli/atom.sh: line 4: case “$'pt” in

I think that the clue is the error from Settings>Install …

‘D:\Programs’ is not recognized as an internal or external command,
operable program or batch file.

There must be some sort of variable that isn’t getting defined properly.


#13

Try putting it in a different folder, one that doesn’t have (x86) in the name. It looks like it is getting confused by that, and thinks the folder is simply called Programs.


#14

I’m giving up. Going to try something else. Thanks for all of the help.