V.180 Crash at Startup


#1

Crash on startup:

/Applications/Development/Atom.app/Contents/Resources/app/src/package.js:194 Failed to load package named ‘release-notes’ Error:
at new Parser (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/less-cache/node_modules/less/lib/less/parser.js:333:27)
at LessCache.module.exports.LessCache.parseLess (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/less-cache/lib/less-cache.js:241:16)
at LessCache.module.exports.LessCache.cssForFile (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/less-cache/lib/less-cache.js:272:20)
at LessCache.module.exports.LessCache.readFileSync (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/less-cache/lib/less-cache.js:260:19)
at LessCompileCache.module.exports.LessCompileCache.read (/Applications/Development/Atom.app/Contents/Resources/app/src/less-compile-cache.js:36:25)
at ThemeManager.module.exports.ThemeManager.loadLessStylesheet (/Applications/Development/Atom.app/Contents/Resources/app/src/theme-manager.js:365:33)
at ThemeManager.module.exports.ThemeManager.loadStylesheet (/Applications/Development/Atom.app/Contents/Resources/app/src/theme-manager.js:341:21)
at ThemeManager.module.exports.ThemeManager.requireStylesheet (/Applications/Development/Atom.app/Contents/Resources/app/src/theme-manager.js:263:24)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/atom-space-pen-views/lib/select-list-view.js:12:15)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/atom-space-pen-views/lib/select-list-view.js:361:4)
at Module._compile (module.js:475:26)
at Object.loadFile [as .js] (/Applications/Development/Atom.app/Contents/Resources/app/src/6to5.js:138:21)
at Module.load (module.js:370:32)
at Function.Module._load (module.js:325:12)
at Module.require (module.js:380:17)
at require (module.js:399:17)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/atom-space-pen-views/lib/main.js:18:28)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/atom-space-pen-views/lib/main.js:22:4)
at Module._compile (module.js:475:26)
at Object.loadFile [as .js] (/Applications/Development/Atom.app/Contents/Resources/app/src/6to5.js:138:21)
at Module.load (module.js:370:32)
at Function.Module._load (module.js:325:12)
at Module.require (module.js:380:17)
at require (module.js:399:17)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/release-notes/lib/release-notes-status-bar.js:6:10)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/release-notes/lib/release-notes-status-bar.js:59:4)
at Module._compile (module.js:475:26)
at Object.loadFile [as .js] (/Applications/Development/Atom.app/Contents/Resources/app/src/6to5.js:138:21)
at Module.load (module.js:370:32)
at Function.Module._load (module.js:325:12)
at Module.require (module.js:380:17)
at require (module.js:399:17)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/release-notes/lib/main.js:8:26)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/release-notes/lib/main.js:82:4)
at Module._compile (module.js:475:26)
at Object.loadFile [as .js] (/Applications/Development/Atom.app/Contents/Resources/app/src/6to5.js:138:21)
at Module.load (module.js:370:32)
at Function.Module._load (module.js:325:12)
at Module.require (module.js:380:17)
at require (module.js:399:17)
at Package.module.exports.Package.requireMainModule (/Applications/Development/Atom.app/Contents/Resources/app/src/package.js:651:34)
at /Applications/Development/Atom.app/Contents/Resources/app/src/package.js:190:28
at Package.module.exports.Package.measure (/Applications/Development/Atom.app/Contents/Resources/app/src/package.js:167:15)
at Package.module.exports.Package.load (/Applications/Development/Atom.app/Contents/Resources/app/src/package.js:181:12)
at PackageManager.module.exports.PackageManager.loadPackage (/Applications/Development/Atom.app/Contents/Resources/app/src/package-manager.js:378:16)
at PackageManager.module.exports.PackageManager.loadPackages (/Applications/Development/Atom.app/Contents/Resources/app/src/package-manager.js:355:14)
at Atom.module.exports.Atom.startEditorWindow (/Applications/Development/Atom.app/Contents/Resources/app/src/atom.js:617:21)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/src/window-bootstrap.js:12:8)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/src/window-bootstrap.js:23:4)
at Module._compile (module.js:475:26)
at Object.loadFile [as .js] (/Applications/Development/Atom.app/Contents/Resources/app/src/6to5.js:138:21)
at Module.load (module.js:370:32)
at Function.Module._load (module.js:325:12)
at Module.require (module.js:380:17)
at require (module.js:399:17)
at window.onload (file:///Applications/Development/Atom.app/Contents/Resources/app/static/index.js:53:25)

/Applications/Development/Atom.app/Contents/Resources/app/src/package.js:194 Failed to load package named ‘status-bar’ Error:
at new Parser (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/less-cache/node_modules/less/lib/less/parser.js:333:27)
at LessCache.module.exports.LessCache.parseLess (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/less-cache/lib/less-cache.js:241:16)
at LessCache.module.exports.LessCache.cssForFile (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/less-cache/lib/less-cache.js:272:20)
at LessCache.module.exports.LessCache.readFileSync (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/less-cache/lib/less-cache.js:260:19)
at LessCompileCache.module.exports.LessCompileCache.read (/Applications/Development/Atom.app/Contents/Resources/app/src/less-compile-cache.js:36:25)
at ThemeManager.module.exports.ThemeManager.loadLessStylesheet (/Applications/Development/Atom.app/Contents/Resources/app/src/theme-manager.js:365:33)
at ThemeManager.module.exports.ThemeManager.loadStylesheet (/Applications/Development/Atom.app/Contents/Resources/app/src/theme-manager.js:341:21)
at ThemeManager.module.exports.ThemeManager.requireStylesheet (/Applications/Development/Atom.app/Contents/Resources/app/src/theme-manager.js:263:24)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/atom-space-pen-views/lib/select-list-view.js:12:15)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/atom-space-pen-views/lib/select-list-view.js:361:4)
at Module._compile (module.js:475:26)
at Object.loadFile [as .js] (/Applications/Development/Atom.app/Contents/Resources/app/src/6to5.js:138:21)
at Module.load (module.js:370:32)
at Function.Module._load (module.js:325:12)
at Module.require (module.js:380:17)
at require (module.js:399:17)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/atom-space-pen-views/lib/main.js:18:28)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/atom-space-pen-views/lib/main.js:22:4)
at Module._compile (module.js:475:26)
at Object.loadFile [as .js] (/Applications/Development/Atom.app/Contents/Resources/app/src/6to5.js:138:21)
at Module.load (module.js:370:32)
at Function.Module._load (module.js:325:12)
at Module.require (module.js:380:17)
at require (module.js:399:17)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/status-bar/lib/main.js:4:7)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/status-bar/lib/main.js:166:4)
at Module._compile (module.js:475:26)
at Object.loadFile [as .js] (/Applications/Development/Atom.app/Contents/Resources/app/src/6to5.js:138:21)
at Module.load (module.js:370:32)
at Function.Module._load (module.js:325:12)
at Module.require (module.js:380:17)
at require (module.js:399:17)
at Package.module.exports.Package.requireMainModule (/Applications/Development/Atom.app/Contents/Resources/app/src/package.js:651:34)
at /Applications/Development/Atom.app/Contents/Resources/app/src/package.js:190:28
at Package.module.exports.Package.measure (/Applications/Development/Atom.app/Contents/Resources/app/src/package.js:167:15)
at Package.module.exports.Package.load (/Applications/Development/Atom.app/Contents/Resources/app/src/package.js:181:12)
at PackageManager.module.exports.PackageManager.loadPackage (/Applications/Development/Atom.app/Contents/Resources/app/src/package-manager.js:378:16)
at PackageManager.module.exports.PackageManager.loadPackages (/Applications/Development/Atom.app/Contents/Resources/app/src/package-manager.js:355:14)
at Atom.module.exports.Atom.startEditorWindow (/Applications/Development/Atom.app/Contents/Resources/app/src/atom.js:617:21)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/src/window-bootstrap.js:12:8)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/src/window-bootstrap.js:23:4)
at Module._compile (module.js:475:26)
at Object.loadFile [as .js] (/Applications/Development/Atom.app/Contents/Resources/app/src/6to5.js:138:21)
at Module.load (module.js:370:32)
at Function.Module._load (module.js:325:12)
at Module.require (module.js:380:17)
at require (module.js:399:17)
at window.onload (file:///Applications/Development/Atom.app/Contents/Resources/app/static/index.js:53:25)

/Applications/Development/Atom.app/Contents/Resources/app/src/package.js:194 Failed to load package named ‘tabs’ Error:
at new Parser (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/less-cache/node_modules/less/lib/less/parser.js:333:27)
at LessCache.module.exports.LessCache.parseLess (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/less-cache/lib/less-cache.js:241:16)
at LessCache.module.exports.LessCache.cssForFile (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/less-cache/lib/less-cache.js:272:20)
at LessCache.module.exports.LessCache.readFileSync (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/less-cache/lib/less-cache.js:260:19)
at LessCompileCache.module.exports.LessCompileCache.read (/Applications/Development/Atom.app/Contents/Resources/app/src/less-compile-cache.js:36:25)
at ThemeManager.module.exports.ThemeManager.loadLessStylesheet (/Applications/Development/Atom.app/Contents/Resources/app/src/theme-manager.js:365:33)
at ThemeManager.module.exports.ThemeManager.loadStylesheet (/Applications/Development/Atom.app/Contents/Resources/app/src/theme-manager.js:341:21)
at ThemeManager.module.exports.ThemeManager.requireStylesheet (/Applications/Development/Atom.app/Contents/Resources/app/src/theme-manager.js:263:24)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/atom-space-pen-views/lib/select-list-view.js:12:15)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/atom-space-pen-views/lib/select-list-view.js:361:4)
at Module._compile (module.js:475:26)
at Object.loadFile [as .js] (/Applications/Development/Atom.app/Contents/Resources/app/src/6to5.js:138:21)
at Module.load (module.js:370:32)
at Function.Module._load (module.js:325:12)
at Module.require (module.js:380:17)
at require (module.js:399:17)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/atom-space-pen-views/lib/main.js:18:28)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/atom-space-pen-views/lib/main.js:22:4)
at Module._compile (module.js:475:26)
at Object.loadFile [as .js] (/Applications/Development/Atom.app/Contents/Resources/app/src/6to5.js:138:21)
at Module.load (module.js:370:32)
at Function.Module._load (module.js:325:12)
at Module.require (module.js:380:17)
at require (module.js:399:17)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/tabs/lib/tab-bar-view.js:11:10)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/tabs/lib/tab-bar-view.js:645:4)
at Module._compile (module.js:475:26)
at Object.loadFile [as .js] (/Applications/Development/Atom.app/Contents/Resources/app/src/6to5.js:138:21)
at Module.load (module.js:370:32)
at Function.Module._load (module.js:325:12)
at Module.require (module.js:380:17)
at require (module.js:399:17)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/tabs/lib/main.js:6:16)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/tabs/lib/main.js:56:4)
at Module._compile (module.js:475:26)
at Object.loadFile [as .js] (/Applications/Development/Atom.app/Contents/Resources/app/src/6to5.js:138:21)
at Module.load (module.js:370:32)
at Function.Module._load (module.js:325:12)
at Module.require (module.js:380:17)
at require (module.js:399:17)
at Package.module.exports.Package.requireMainModule (/Applications/Development/Atom.app/Contents/Resources/app/src/package.js:651:34)
at /Applications/Development/Atom.app/Contents/Resources/app/src/package.js:190:28
at Package.module.exports.Package.measure (/Applications/Development/Atom.app/Contents/Resources/app/src/package.js:167:15)
at Package.module.exports.Package.load (/Applications/Development/Atom.app/Contents/Resources/app/src/package.js:181:12)
at PackageManager.module.exports.PackageManager.loadPackage (/Applications/Development/Atom.app/Contents/Resources/app/src/package-manager.js:378:16)
at PackageManager.module.exports.PackageManager.loadPackages (/Applications/Development/Atom.app/Contents/Resources/app/src/package-manager.js:355:14)
at Atom.module.exports.Atom.startEditorWindow (/Applications/Development/Atom.app/Contents/Resources/app/src/atom.js:617:21)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/src/window-bootstrap.js:12:8)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/src/window-bootstrap.js:23:4)
at Module._compile (module.js:475:26)
at Object.loadFile [as .js] (/Applications/Development/Atom.app/Contents/Resources/app/src/6to5.js:138:21)
at Module.load (module.js:370:32)
at Function.Module._load (module.js:325:12)
at Module.require (module.js:380:17)
at require (module.js:399:17)
at window.onload (file:///Applications/Development/Atom.app/Contents/Resources/app/static/index.js:53:25)

index.js:66 Error:
at new Parser (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/less-cache/node_modules/less/lib/less/parser.js:333:27)
at LessCache.module.exports.LessCache.parseLess (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/less-cache/lib/less-cache.js:241:16)
at LessCache.module.exports.LessCache.cssForFile (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/less-cache/lib/less-cache.js:272:20)
at LessCache.module.exports.LessCache.readFileSync (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/less-cache/lib/less-cache.js:260:19)
at LessCompileCache.module.exports.LessCompileCache.read (/Applications/Development/Atom.app/Contents/Resources/app/src/less-compile-cache.js:36:25)
at ThemeManager.module.exports.ThemeManager.loadLessStylesheet (/Applications/Development/Atom.app/Contents/Resources/app/src/theme-manager.js:365:33)
at ThemeManager.module.exports.ThemeManager.loadStylesheet (/Applications/Development/Atom.app/Contents/Resources/app/src/theme-manager.js:341:21)
at ThemeManager.module.exports.ThemeManager.requireStylesheet (/Applications/Development/Atom.app/Contents/Resources/app/src/theme-manager.js:263:24)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/atom-space-pen-views/lib/select-list-view.js:12:15)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/atom-space-pen-views/lib/select-list-view.js:361:4)
at Module._compile (module.js:475:26)
at Object.loadFile [as .js] (/Applications/Development/Atom.app/Contents/Resources/app/src/6to5.js:138:21)
at Module.load (module.js:370:32)
at Function.Module._load (module.js:325:12)
at Module.require (module.js:380:17)
at require (module.js:399:17)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/atom-space-pen-views/lib/main.js:18:28)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/atom-space-pen-views/lib/main.js:22:4)
at Module._compile (module.js:475:26)
at Object.loadFile [as .js] (/Applications/Development/Atom.app/Contents/Resources/app/src/6to5.js:138:21)
at Module.load (module.js:370:32)
at Function.Module._load (module.js:325:12)
at Module.require (module.js:380:17)
at require (module.js:399:17)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/settings-view/lib/settings-view.js:10:10)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/settings-view/lib/settings-view.js:380:4)
at Module._compile (module.js:475:26)
at Object.loadFile [as .js] (/Applications/Development/Atom.app/Contents/Resources/app/src/6to5.js:138:21)
at Module.load (module.js:370:32)
at Function.Module._load (module.js:325:12)
at Module.require (module.js:380:17)
at require (module.js:399:17)
at createSettingsView (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/settings-view/lib/main.js:12:22)
at Object.deserializer.deserialize (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/settings-view/lib/main.js:31:16)
at DeserializerManager.module.exports.DeserializerManager.deserialize (/Applications/Development/Atom.app/Contents/Resources/app/src/deserializer-manager.js:56:29)
at /Applications/Development/Atom.app/Contents/Resources/app/src/pane.js:81:35
at Array.map (native)
at Pane.module.exports.Pane.deserializeParams (/Applications/Development/Atom.app/Contents/Resources/app/src/pane.js:80:36)
at Function.module.exports.Serializable.deserialize (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/serializable/lib/serializable.js:58:25)
at DeserializerManager.module.exports.DeserializerManager.deserialize (/Applications/Development/Atom.app/Contents/Resources/app/src/deserializer-manager.js:56:29)
at PaneContainer.module.exports.PaneContainer.deserializeParams (/Applications/Development/Atom.app/Contents/Resources/app/src/pane-container.js:71:40)
at Function.module.exports.Serializable.deserialize (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/serializable/lib/serializable.js:58:25)
at Workspace.module.exports.Workspace.deserializeParams (/Applications/Development/Atom.app/Contents/Resources/app/src/workspace.js:138:44)
at Function.module.exports.Serializable.deserialize (/Applications/Development/Atom.app/Contents/Resources/app/node_modules/serializable/lib/serializable.js:58:25)
at Atom.module.exports.Atom.deserializeWorkspaceView (/Applications/Development/Atom.app/Contents/Resources/app/src/atom.js:750:43)
at Atom.module.exports.Atom.deserializeEditorWindow (/Applications/Development/Atom.app/Contents/Resources/app/src/atom.js:767:19)
at Atom.module.exports.Atom.startEditorWindow (/Applications/Development/Atom.app/Contents/Resources/app/src/atom.js:618:12)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/src/window-bootstrap.js:12:8)
at Object. (/Applications/Development/Atom.app/Contents/Resources/app/src/window-bootstrap.js:23:4)
at Module._compile (module.js:475:26)
at Object.loadFile [as .js] (/Applications/Development/Atom.app/Contents/Resources/app/src/6to5.js:138:21)
at Module.load (module.js:370:32)
at Function.Module._load (module.js:325:12)
at Module.require (module.js:380:17)
at require (module.js:399:17)
at window.onload (file:///Applications/Development/Atom.app/Contents/Resources/app/static/index.js:53:25)
index.js:66 window.onload


#2

It looks like everything didn’t install correctly, what I’d suggest is a fresh install, delete everything and download the Windows installer. Fingers crossed it works for cha :slight_smile: