Using atom as your default editor


#1

To use atom as your default editor, set your EDITOR environment variable to EDITOR=/usr/local/bin/atom --wait.

The --wait option, which I used with TextMate’s mate tool also appears to work here.

I didn’t see this documented anywhere so I thought I’d share it.


#2

It’s at least documented in the help: atom --help That’s where I found out about it :smile:


#3

You’re right, thanks. I think I tried atom -? instead of -h.


#4

Having these tidbits in the boards help the people who search for answers. Thanks for contributing! :smiley:


#5

Maybe help should work with those command line parameter aliases too?


#6

I honestly don’t know why I used -? instead of the more common -h. Having a weird day, I guess :smile:

Actually the first thing I tried was man atom, so perhaps a man page would help – even if it was little more than the output of atom -h.