Upgrading problems: _shim.js?


#1

Hi all,

I upgraded an Electron application which was running fine using 1.4.15 and was installed on Windows using a NSIS build.

I upgraded to version 1.7.8 using Node version 7.9.0 and now the application can be started and the NSIS build created, but when I start the installed application I get the following error:

error

What could be the problem?

Thanks for any help!

Regards,

Jeroen


#2

How you are building your app
electron packager/electron builder/electron-forge.

did you upgraded builder packages also ? above mentioned modules.
May be new dependency which is not available in old version builder tools