Updating packages have started to fail on windows? [SOLVED]


#1

I have windows 7, ATOM 1.3.0-beta1 (have been broken for me however for two weeks I think)

I tried reinstalling Visual studio 2013 community edition today, but alas it did not help.

I get the following error message:

Updating to “atom-beautify@0.28.18” failed.Hide output…gyp info it worked if it ends with ok
gyp info using node-gyp@2.0.2
gyp info using node@0.10.40 | win32 | ia32
gyp http GET https://atom.io/download/atom-shell/v0.34.3/node-v0.34.3.tar.gz
gyp WARN 
Compiler tools not foundPackages that depend on modules that contain C/C++ code will fail to install.Read here for instructions on installing Python and Visual Studio.Run apm install --check after installing to test compiling a native module.

Any help appreciated!

Also, the link provided forwards to


#2

The build instructions for Windows can be found here:


#3

Has the requirement for python in C:\Python27 changed?

I have always had it in C:\Anaconda, and it worked some weeks ago. Unfortunately I do not have enough privileges on my computer to use mklink.

Any workarounds?


#4

Had an admin fix the mklink, but it did not work.

Tried to reinstall both node js, github desktop, and visual studio 2013 update 5.

Is it possible to get a more detailed error report what went wrong? Right now it only states Packages that depend on modules that contain C/C++ code will fail to install.


#5

It’s saying that it can’t find the compiler tools, I would assume that means that it can’t find some component of Visual Studio. @raelyard, do you have any suggestions?


#6

I have reinstalled atom, also deleting everyting in .atom etc. Anyone having the same issues? I am unsure of how to debug this


#7

Spent 6 hours on this, finally this worked:

set ATOM_NODE_URL=http://gh-contractor-zcbenz.s3.amazonaws.com/atom-shell/dist

Seem my coorporate proxy was behind it, but everything worked fine, listing updates, updating atom etc. So I never thought of trying out proxy things.

Anyway, for anyone with the same issue, hope it helps. TedThiCo’s reply in https://github.com/atom/apm/issues/322#issuecomment-96430856


Can't install any packages - Windows 7